aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/howl/howl_1.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/howl/howl_1.0.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/howl/howl_1.0.0.bb')
-rw-r--r--recipes/howl/howl_1.0.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/howl/howl_1.0.0.bb b/recipes/howl/howl_1.0.0.bb
new file mode 100644
index 0000000000..9acc33018c
--- /dev/null
+++ b/recipes/howl/howl_1.0.0.bb
@@ -0,0 +1,28 @@
+SRC_URI = "http://www.porchdogsoft.com/download/howl-${PV}.tar.gz \
+ file://posix.patch;patch=1;pnum=0 \
+ file://configure.patch;patch=1;pnum=0 \
+ file://mdnsresponder.init"
+LICENSE = "howl"
+
+PR = "r2"
+
+INITSCRIPT_NAME = "mdnsresponder"
+INITSCRIPT_PARAMS = "defaults"
+
+PACKAGES += "libhowl libmdnsresponder"
+
+FILES_${PN} = "${bindir} ${sbindir} ${sysconfdir}"
+FILES_libhowl = "${libdir}/libhowl.so.*"
+FILES_libmdnsresponder = "${libdir}/libmDNSResponder.so.*"
+FILES_${PN}-doc += "${datadir}/howl/help"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sbindir}
+ install -m 0755 ${WORKDIR}/mdnsresponder.init ${D}${sysconfdir}/init.d/mdnsresponder
+ # Debian puts it here, so let's do the same
+ mv ${D}${bindir}/mDNSResponder ${D}${sbindir}
+}
+
+inherit autotools update-rc.d
+