aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hplip
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-09-21 10:48:22 +0200
committerEric Bénard <eric@eukrea.com>2010-09-24 15:15:44 +0200
commit4dedac4c72c33a38261e37cda0ed94b24e4b8563 (patch)
tree074eaa7b726315d2bfc94132c0f9a2d220e72456 /recipes/hplip
parentf7c547ede1bfc94c24f6315a23ff48a4c5b9ffaf (diff)
downloadopenembedded-4dedac4c72c33a38261e37cda0ed94b24e4b8563.tar.gz
hplip: add 3.10.6
* tested on armv5te using HP PSC inkjet printers * DEFAULT_PREFERENCE = "-1" until it's more tested Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes/hplip')
-rw-r--r--recipes/hplip/hplip_3.10.6.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/recipes/hplip/hplip_3.10.6.bb b/recipes/hplip/hplip_3.10.6.bb
new file mode 100644
index 0000000000..d9dfe1daa4
--- /dev/null
+++ b/recipes/hplip/hplip_3.10.6.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "HP Linux Imaging and Printing"
+LICENSE = "GPL, MIT, BSD"
+
+# currently, we build a stripped down version that only includes IJS
+# and components required to implement a minimal printing system
+# for embedded systems.
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ "
+
+PR = "r1"
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools
+
+EXTRA_OECONF = ' \
+ BUILD_SYS="" HOST_SYS="" \
+ --enable-hpijs-install \
+ --disable-network-build \
+ --disable-doc-build \
+ --disable-pp-build \
+ --disable-scan-build \
+ --disable-gui-build \
+ --disable-fax-build \
+ --disable-dbus-build \
+ --disable-foomatic-drv-install \
+ --disable-foomatic-rip-hplip-install \
+ '
+
+# needed by python checks in configure
+EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
+
+PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter"
+RDEPENDS_${PN} += "python-syslog python-pprint python-compression python-shell python-xml python-unixadmin python-html python-resource python-terminal"
+
+# need to snag the debug file or OE will fail on backend package
+FILES_${PN}-dbg += "\
+ ${libdir}/cups/backend/.debug \
+ ${libdir}/python2.6/site-packages/.debug \
+ ${libdir}/cups/filter/.debug "
+
+FILES_${PN}-ppd = "\
+ ${datadir}/ppd"
+
+FILES_${PN}-cups = "\
+ ${datadir}/cups"
+
+FILES_${PN}-backend = "\
+ ${libdir}/cups/backend"
+
+FILES_${PN}-filter = "\
+ ${libdir}/cups/filter"
+
+FILES_${PN} += "\
+ ${libdir}/python2.6/site-packages/*.so"
+
+SRC_URI[md5sum] = "96c36e3baf35e93cf9436a772f0c9ef4"
+SRC_URI[sha256sum] = "3ee0e68a613d2b966dcb6df9fd8e074c4c3e590249e61c0d792de3373b84fdeb"
+