aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hplip
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2011-04-01 11:23:13 -0700
committerKoen Kooi <koen@openembedded.org>2011-05-08 20:24:23 +0200
commitf73affe12718ef91a2dc9932565b31c00fce9cd5 (patch)
tree7e9be7e439524be3fb9ae440593c9f298297336f /recipes/hplip
parentde428183514adcf1a0159b32674ab1fbcf8e03ef (diff)
downloadopenembedded-f73affe12718ef91a2dc9932565b31c00fce9cd5.tar.gz
hplip: Add recipe for 3.11.3a
Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/hplip')
-rw-r--r--recipes/hplip/hplip_3.11.3a.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes/hplip/hplip_3.11.3a.bb b/recipes/hplip/hplip_3.11.3a.bb
new file mode 100644
index 0000000000..5e8298908c
--- /dev/null
+++ b/recipes/hplip/hplip_3.11.3a.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "HP Linux Imaging and Printing"
+LICENSE = "GPL, MIT, BSD"
+
+DEPENDS = "cups net-snmp"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
+ "
+inherit autotools
+
+EXTRA_OECONF = ' \
+ BUILD_SYS="" HOST_SYS="" \
+ --enable-hpijs-install \
+ --enable-gui-build \
+ --enable-pp-build \
+ --enable-policy-kit \
+ --disable-scan-build \
+ --enable-foomatic-ppd-install \
+ --enable-foomatic-drv-install \
+ --enable-udev-acl-rules \
+ '
+
+# needed by python checks in configure
+EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
+
+do_install_prepend() {
+ sed -i -e s:SYSFS:ATTRS:g data/rules/55-hpmud.rules
+ sed -i -e s:SYSFS:ATTRS:g data/rules/56-hpmud_support.rules
+}
+
+PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter"
+RDEPENDS_${PN} += "net-snmp-client python-syslog python-pprint python-compression python-shell python-xml python-unixadmin python-html python-resource python-terminal"
+
+# need to snag the debug file or OE will fail on backend package
+FILES_${PN}-dbg += "\
+ ${libdir}/cups/backend/.debug \
+ ${libdir}/python2.6/site-packages/.debug \
+ ${libdir}/cups/filter/.debug "
+
+FILES_${PN}-ppd = "\
+ ${datadir}/ppd"
+
+FILES_${PN}-cups = "\
+ ${datadir}/cups"
+
+FILES_${PN}-backend = "\
+ ${libdir}/cups/backend"
+
+FILES_${PN}-filter = "\
+ ${libdir}/cups/filter"
+
+FILES_${PN} += "\
+ ${libdir}/python2.6/site-packages \
+ ${datadir}/hal/fdi/preprobe/10osvendor \
+ "
+
+SRC_URI[md5sum] = "967e095bec457b4acc858774d673f884"
+SRC_URI[sha256sum] = "ec51d275a91fcb54e9191c0f1475d5c742e659ca94f97f0be2d507d1091be569"
+