aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/hugs/hugs_hugs98-Nov2003.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hugs/hugs_hugs98-Nov2003.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hugs/hugs_hugs98-Nov2003.bb')
-rw-r--r--recipes/hugs/hugs_hugs98-Nov2003.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/hugs/hugs_hugs98-Nov2003.bb b/recipes/hugs/hugs_hugs98-Nov2003.bb
new file mode 100644
index 0000000000..0269e7c4cb
--- /dev/null
+++ b/recipes/hugs/hugs_hugs98-Nov2003.bb
@@ -0,0 +1,31 @@
+DEPENDS = "readline"
+SRC_URI = "http://cvs.haskell.org/Hugs/downloads/Nov2003/${PV}.tar.gz \
+ file://hugs.desktop \
+ file://hugs.png"
+LICENSE = "BSD"
+PR = "r2"
+
+S = "${WORKDIR}/${PV}/src/unix"
+
+inherit autotools
+
+# disable STRIP as the generated Makefile falsely call arm-linux-strip
+# on compiling which leads to abortion of the compile
+# we strip manually anyway so disabling it here is 'ok'
+EXTRA_OECONF = "--disable-ffi STRIP=true"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd ../ && oe_runmake
+}
+
+do_install() {
+ cd ../ && autotools_do_install
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/hugs.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/hugs.png ${D}${datadir}/pixmaps/
+}