summaryrefslogtreecommitdiffstats
path: root/recipes/iaimaster
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/iaimaster
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/iaimaster')
-rwxr-xr-xrecipes/iaimaster/files/iaimaster.desktop7
-rwxr-xr-xrecipes/iaimaster/files/iaimaster.pngbin0 -> 2458 bytes
-rw-r--r--recipes/iaimaster/iaimaster_0.5.bb26
3 files changed, 33 insertions, 0 deletions
diff --git a/recipes/iaimaster/files/iaimaster.desktop b/recipes/iaimaster/files/iaimaster.desktop
new file mode 100755
index 0000000000..0874168f42
--- /dev/null
+++ b/recipes/iaimaster/files/iaimaster.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Comment=pen action mini game. you fight evil Iai-Master and must survive. (Iai is a kind of the samurai fighting style)
+Exec=iaimaster
+Icon=iaimaster
+Type=Application
+Name=IaiMaster
+CanFastload=0
diff --git a/recipes/iaimaster/files/iaimaster.png b/recipes/iaimaster/files/iaimaster.png
new file mode 100755
index 0000000000..b197afc6d6
--- /dev/null
+++ b/recipes/iaimaster/files/iaimaster.png
Binary files differ
diff --git a/recipes/iaimaster/iaimaster_0.5.bb b/recipes/iaimaster/iaimaster_0.5.bb
new file mode 100644
index 0000000000..e86cf361b4
--- /dev/null
+++ b/recipes/iaimaster/iaimaster_0.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Pen action mini game. You fight evil Iai-Master and must survive. \
+(Iai is a kind of the samurai fighting style)"
+SECTION = "opie/games"
+LICENSE = "GPL"
+APPNAME = "${PN}"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+SRC_URI = "http://www.urban.ne.jp/home/kanemori/zaurus/IaiMaster_${PV}.tar.gz \
+ file://iaimaster.desktop \
+ file://iaimaster.png"
+S = "${WORKDIR}/IaiMaster"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "TARGET=${PN}"
+
+do_configure_prepend() {
+ qmake -project
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/iaimaster.png ${D}${palmtopdir}/pics/
+}
+