aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ica
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ica
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ica')
-rw-r--r--recipes/ica/ica-bin_10.6.bb30
-rw-r--r--recipes/ica/ica-bin_8.0.bb54
2 files changed, 84 insertions, 0 deletions
diff --git a/recipes/ica/ica-bin_10.6.bb b/recipes/ica/ica-bin_10.6.bb
new file mode 100644
index 0000000000..201950559d
--- /dev/null
+++ b/recipes/ica/ica-bin_10.6.bb
@@ -0,0 +1,30 @@
+# ica-bin OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DEPENDS = "virtual/libx11 libxaw rpm2cpio-native fakeroot-native"
+RDEPENDS = "libxaw"
+
+HOMEPAGE="www.citrix.com/download/"
+
+SRC_URI="ftp://download2.citrix.com/FILES/en/products/Linux10/ICAClient-10.6-1.i386.rpm"
+
+S="${WORKDIR}"
+FILES_${PN} += "/"
+FILES_${PN}-dbg += "/usr/lib/ICAClient/.debug"
+
+do_configure() {
+ rpm2cpio.pl ${DL_DIR}/ICAClient-${PV}-1.i386.rpm | fakeroot cpio -i --make-directories
+}
+
+DDIR="${D}/usr/lib/ICAClient"
+
+do_install () {
+ for file in `find usr/lib/ICAClient/ -type d`; do
+ install -d ${D}/$file
+ done
+
+ for file in `find usr/lib/ICAClient/ -type f`; do
+ install $file ${D}/$file
+ done
+}
diff --git a/recipes/ica/ica-bin_8.0.bb b/recipes/ica/ica-bin_8.0.bb
new file mode 100644
index 0000000000..ede48ffe3b
--- /dev/null
+++ b/recipes/ica/ica-bin_8.0.bb
@@ -0,0 +1,54 @@
+# ica-bin OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DEPENDS = "virtual/libx11 libxaw rpm2cpio-native"
+
+HOMEPAGE="www.citrix.com/download/"
+
+SRC_URI="file://${DL_DIR}/ICAClient-8.0-1.i386.rpm"
+
+S="${WORKDIR}"
+PACKAGES= "${PN}"
+FILES_${PN} = "/"
+
+python ica_do_fetch() {
+ import os
+ def dowarn(str,d):
+ out = bb.data.expand(str, d)
+ bb.note(out)
+
+ file = bb.data.getVar('A', d)
+ basen = os.path.basename(file)
+
+ if not os.path.exists(file):
+ dowarn('You need to perform the following steps to build this package:',d)
+ dowarn('Sign up at ${HOMEPAGE}',d)
+ dowarn('- Download %s and place it in ${DL_DIR}' % basen,d)
+ dowarn('- make this package again',d)
+ raise bb.build.FuncFailed('Package not downloaded')
+}
+
+python do_fetch() {
+ bb.build.exec_func('ica_do_fetch', d)
+ bb.build.exec_func('base_do_fetch', d)
+}
+
+do_unpack() {
+ rpm2cpio.pl ${A} | cpio -i --make-directories
+}
+
+do_compile() {
+}
+
+DDIR="${D}/usr/lib/ICAClient"
+
+do_install () {
+ for file in `find usr/lib/ICAClient/ -type d`; do
+ install -d ${D}/$file
+ done
+
+ for file in `find usr/lib/ICAClient/ -type f`; do
+ install $file ${D}/$file
+ done
+}