aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-02-17 19:20:31 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-02-21 12:32:48 +0100
commit15a779668b410618579541c924e5e4c5cf4cd0f6 (patch)
tree05220594d6c381ad8227593e1287e89b6f8d84d7 /recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
parent77986e980258cd6b976e56fa0239ae0a4fdc01f9 (diff)
downloadopenembedded-15a779668b410618579541c924e5e4c5cf4cd0f6.tar.gz
icedtea6-native: add linux kernel version 3 support
* bump PR
Diffstat (limited to 'recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch')
-rw-r--r--recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch b/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
new file mode 100644
index 0000000000..925ca6c084
--- /dev/null
+++ b/recipes/icedtea/icedtea6-native-1.7.10/icedtea-support_linux_3.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User andrew
+# Date 1309217125 -3600
+# Node ID f7e8b10f51c6a622520b55df0c644fb09ec78542
+# Parent b8227c320dec384a94026fcaa650b0ebd4eef13b
+Allow building HotSpot with any Linux 3 version.
+
+diff -r b8227c320dec -r f7e8b10f51c6 make/linux/Makefile
+--- openjdk/hotspot/make/linux/Makefile Wed Jun 15 18:56:52 2011 +0100
++++ openjdk/hotspot/make/linux/Makefile Tue Jun 28 00:25:25 2011 +0100
+@@ -230,7 +230,7 @@
+ # Solaris 2.5.1, 2.6).
+ # Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
+
+-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 2.7%
++SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3%
+ OS_VERSION := $(shell uname -r)
+ EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
+