aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icewm
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/icewm
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/icewm')
-rw-r--r--recipes/icewm/icewm-1.2.30/configure.patch22
-rw-r--r--recipes/icewm/icewm-1.2.30/makefile.patch23
-rw-r--r--recipes/icewm/icewm_1.2.30.bb26
3 files changed, 71 insertions, 0 deletions
diff --git a/recipes/icewm/icewm-1.2.30/configure.patch b/recipes/icewm/icewm-1.2.30/configure.patch
new file mode 100644
index 0000000000..ade427d5e0
--- /dev/null
+++ b/recipes/icewm/icewm-1.2.30/configure.patch
@@ -0,0 +1,22 @@
+--- icewm-1.2.26/configure.in.orig 2006-07-18 15:16:37.024817360 -0600
++++ icewm-1.2.26/configure.in 2006-07-18 15:17:32.889324664 -0600
+@@ -426,14 +426,11 @@
+ AC_MSG_ERROR("xfreetype or core fonts must be enabled")
+ fi
+ if test "$enable_xfreetype" != "no" -o "$enable_xfreetype" = "implied"; then
+- AC_PATH_PROG(XFT_CONFIG, xft-config,, ${with_xft_arg-${PATH}})
+- if test "${XFT_CONFIG}" == ""; then
+- AC_PATH_PROG(PKG_CONFIG, pkg-config)
+- if test "${PKG_CONFIG}" != ""; then
+- ${PKG_CONFIG} xft 2>/dev/null
+- if test $? -eq 0 ; then
+- XFT_CONFIG='pkg-config xft'
+- fi
++ AC_PATH_PROG(PKG_CONFIG, pkg-config)
++ if test "${PKG_CONFIG}" != ""; then
++ ${PKG_CONFIG} xft 2>/dev/null
++ if test $? -eq 0 ; then
++ XFT_CONFIG='pkg-config xft'
+ fi
+ fi
+ if test "${XFT_CONFIG}" != ""; then
diff --git a/recipes/icewm/icewm-1.2.30/makefile.patch b/recipes/icewm/icewm-1.2.30/makefile.patch
new file mode 100644
index 0000000000..753f6a57a2
--- /dev/null
+++ b/recipes/icewm/icewm-1.2.30/makefile.patch
@@ -0,0 +1,23 @@
+--- ./src/Makefile.in 2005-02-01 21:56:08.000000000 +0100
++++ ./src/Makefile.in 2005-02-01 21:55:12.000000000 +0100
+@@ -206,10 +206,18 @@
+ %.o: %.cc
+ @echo " CXX " $@
+ @$(CXX) $(CXXFLAGS) $(GCCDEP) -c $<
+-
+-genpref $(BINARIES):
++
++genpref.o: genpref.cc
++ @echo " BUILD_CXX " $@
++ @$(BUILD_CXX) $(BUILD_CXXFLAGS) $(DEBUG) $(DEFS) $(GCCDEP) -c $<
++
++$(BINARIES):
+ @echo " LD " $@
+ @$(LD) -o $@$(EXEEXT) $($@_OBJS) $(LFLAGS) $($@_LFLAGS) $(LIBS) $($@_LIBS)
++
++genpref:
++ @echo " BUILD_CXX " $@
++ @$(BUILD_CXX) $(BUILD_LDFLAGS) -o $@$(EXEEXT) $($@_OBJS) $(LIBS) $($@_LIBS)
+
+ ################################################################################
+
diff --git a/recipes/icewm/icewm_1.2.30.bb b/recipes/icewm/icewm_1.2.30.bb
new file mode 100644
index 0000000000..cd8cfe5bde
--- /dev/null
+++ b/recipes/icewm/icewm_1.2.30.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "IceWM Window Manager"
+SECTION = "x11/wm"
+LICENSE = "GPL"
+DEPENDS = "virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender libxinerama libxpm xrandr xft mkfontdir-native"
+RRECOMMENDS = "ttf-dejavu-sans"
+PR = "r2"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/icewm/icewm-${PV}.tar.gz \
+ file://makefile.patch;patch=1 \
+ file://configure.patch;patch=1 \
+"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-i18n --without-imlib --with-xpm --with-gnome-menus \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} \
+ --with-mkfontdir=${STAGING_BINDIR_NATIVE}/mkfontdir"
+
+pkg_postinst() {
+update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/icewm-session 10
+}
+
+pkg_postrm() {
+update-alternatives --remove x-window-manager /usr/bin/icewm-session
+}