aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icu/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/icu/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/icu/files')
-rw-r--r--recipes/icu/files/use-g++-for-linking.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes/icu/files/use-g++-for-linking.patch b/recipes/icu/files/use-g++-for-linking.patch
new file mode 100644
index 0000000000..4702abc065
--- /dev/null
+++ b/recipes/icu/files/use-g++-for-linking.patch
@@ -0,0 +1,67 @@
+---
+ tools/genccode/Makefile.in | 2 +-
+ tools/gencmn/Makefile.in | 2 +-
+ tools/genrb/Makefile.in | 2 +-
+ tools/pkgdata/Makefile.in | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+--- source.orig/tools/genccode/Makefile.in
++++ source/tools/genccode/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+--- source.orig/tools/gencmn/Makefile.in
++++ source/tools/gencmn/Makefile.in
+@@ -76,11 +76,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+--- source.orig/tools/genrb/Makefile.in
++++ source/tools/genrb/Makefile.in
+@@ -84,11 +84,11 @@ Makefile: $(srcdir)/Makefile.in $(top_b
+
+ $(TARGET) : $(OBJECTS)
+ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+ $(DERB) : $(DERB_OBJ)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ # This line is needed to serialize builds when the gmake -j option is used.
+ $(TARGET_STUB_NAME).$(SECTION): $(DERB_STUB_NAME).$(SECTION)
+
+--- source.orig/tools/pkgdata/Makefile.in
++++ source/tools/pkgdata/Makefile.in
+@@ -81,11 +81,11 @@ check-local: all-local
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ $(TARGET) : $(OBJECTS)
+- $(LINK.c) $(OUTOPT)$@ $^ $(LIBS)
++ $(LINK.cc) $(OUTOPT)$@ $^ $(LIBS)
+
+
+ %.$(SECTION): $(srcdir)/%.$(SECTION).in
+ cd $(top_builddir) \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status