aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/icu
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-05-18 15:22:21 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-05-18 15:22:21 +0200
commit798c780a3a016e56d9b8849cf8a07521b6e402a9 (patch)
tree6ff9f7e4ec5d186043b4a530395714779ff8eadd /recipes/icu
parentb6242ec579d817b952208f2367f2bed417ec9d9d (diff)
downloadopenembedded-798c780a3a016e56d9b8849cf8a07521b6e402a9.tar.gz
icu: Apply patch working around a gcc bug.
Diffstat (limited to 'recipes/icu')
-rw-r--r--recipes/icu/files/rematch-gcc-bug.patch12
-rw-r--r--recipes/icu/icu_3.6.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes/icu/files/rematch-gcc-bug.patch b/recipes/icu/files/rematch-gcc-bug.patch
new file mode 100644
index 0000000000..4d47056ac5
--- /dev/null
+++ b/recipes/icu/files/rematch-gcc-bug.patch
@@ -0,0 +1,12 @@
+--- a/i18n/Makefile.in 2009-05-18 13:55:49.000000000 +0200
++++ b/i18n/Makefile.in 2009-05-18 13:55:49.000000000 +0200
+@@ -105,6 +105,9 @@
+
+ all-local: $(ALL_TARGETS)
+
++rematch.o: $(srcdir)/rematch.cpp
++ $(CXX) $(CPPFLAGS) $(DEFS) -c -o $@ $<
++
+ install-local: install-headers install-library
+
+ install-library: all-local
diff --git a/recipes/icu/icu_3.6.bb b/recipes/icu/icu_3.6.bb
index 1dbdf94b3a..3eccfb53d9 100644
--- a/recipes/icu/icu_3.6.bb
+++ b/recipes/icu/icu_3.6.bb
@@ -3,7 +3,8 @@ require icu-3.6.inc
DEPENDS += "icu-native"
PR = "r4"
-SRC_URI += "file://use-g++-for-linking.patch;patch=1"
+SRC_URI += "file://use-g++-for-linking.patch;patch=1 \
+ file://rematch-gcc-bug.patch;patch=1"
do_configure_append() {
for i in */Makefile */*.inc */*/Makefile */*/*.inc ; do