aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/imagemagick/imagemagick_6.4.4-1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/imagemagick/imagemagick_6.4.4-1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/imagemagick/imagemagick_6.4.4-1.bb')
-rw-r--r--recipes/imagemagick/imagemagick_6.4.4-1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/imagemagick/imagemagick_6.4.4-1.bb b/recipes/imagemagick/imagemagick_6.4.4-1.bb
new file mode 100644
index 0000000000..42bf1b8bb6
--- /dev/null
+++ b/recipes/imagemagick/imagemagick_6.4.4-1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "ImageMagick is an image convertion tools"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "tiff"
+
+SRC_URI = "ftp://ftp.nluug.nl/pub/ImageMagick/ImageMagick-${PV}.tar.bz2 \
+ file://PerlMagic_MakePatch;patch=1 \
+ "
+
+IMVER = "6.4.4"
+
+S = "${WORKDIR}/ImageMagick-${IMVER}"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_AUTORECONF += "--exclude=libtoolize"
+EXTRA_OECONF = "--without-x --without-freetype --without-perl --disable-openmp"
+
+do_configure() {
+ gnu-configize
+ cp config.{sub,guess} config/
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/ImageMagick-${IMVER}/modules-Q16/*/*.so \
+ ${libdir}/ImageMagick-${IMVER}/modules-Q16/*/*.la \
+ ${libdir}/ImageMagick-${IMVER}/config/ \
+ ${datadir}/ImageMagick-${IMVER}"
+
+FILES_${PN}-dev += "${libdir}/ImageMagick-${IMVER}/modules-Q16/*/*.a"
+
+FILES_${PN}-dbg += "${libdir}/ImageMagick-${IMVER}/modules-Q16/*/.debug/*"
+
+LEAD_SONAME = "libMagickCore.so.*"
+