aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/console-at91sam9-image.bb
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2011-02-01 04:59:14 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-12 09:23:17 -0700
commit572e6ae04d17e9be20c019e32f3e3c47368b9162 (patch)
tree5420bbd65247cbf02a1d07021163a8f98c82d936 /recipes/images/console-at91sam9-image.bb
parent1a5aaae5ad3a4faef55ccbac82ca0300aaa04f14 (diff)
downloadopenembedded-572e6ae04d17e9be20c019e32f3e3c47368b9162.tar.gz
Add basic at91 image with Wi-Fi support
Signed-off-by: Ulf Samuelsson <ulf.samuelsson@atmel.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/images/console-at91sam9-image.bb')
-rw-r--r--recipes/images/console-at91sam9-image.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/images/console-at91sam9-image.bb b/recipes/images/console-at91sam9-image.bb
new file mode 100644
index 0000000000..8b066e283f
--- /dev/null
+++ b/recipes/images/console-at91sam9-image.bb
@@ -0,0 +1,35 @@
+#Angstrom bootstrap at91sam9 image
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+ANGSTROM_EXTRA_INSTALL += " \
+ alsa-utils-amixer \
+ alsa-utils-aplay \
+ dosfstools \
+ iperf \
+ madplay \
+ mplayer \
+ mtd-utils \
+# nbench-byte \
+ owl-wifi \
+ thttpd \
+ usbview \
+ "
+
+DEPENDS = "task-base-extended \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+IMAGE_INSTALL = "task-base-extended \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+export IMAGE_BASENAME = "console-at91sam9-image"
+IMAGE_LINGUAS = ""
+
+#we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND += "rm -f ${IMAGE_ROOTFS}/boot/*Image*; "
+
+inherit image
+