summaryrefslogtreecommitdiffstats
path: root/recipes/images/e-image-core.bb
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-02-12 16:47:14 +0100
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-02-13 02:03:59 +0100
commit60af72f1aff5d64d6f4841d1259d7c437c12e9cd (patch)
treeba2fa14ea45d23ff68520931d68e61bc20c15d57 /recipes/images/e-image-core.bb
parent4facd26dbd345ab60aa5d4d1513323158a9f91eb (diff)
downloadopenembedded-60af72f1aff5d64d6f4841d1259d7c437c12e9cd.tar.gz
e-image-core: change hardcoded kdrive to the correct variables
e-image-core used xserver-kdrive in DEPENDS and xserver-kdrive-fbdev in IMAGE_INSTALL That is wrong because every machine can have different needs (for instance one machine would need/want Xvesa) The correct thing to do is to use ${XSERVER} instead hrw also thought that it was a bug: Feb 12 15:02:06 <hrw> which is a bug
Diffstat (limited to 'recipes/images/e-image-core.bb')
-rw-r--r--recipes/images/e-image-core.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/images/e-image-core.bb b/recipes/images/e-image-core.bb
index f6e0c33659..0eec2b99d1 100644
--- a/recipes/images/e-image-core.bb
+++ b/recipes/images/e-image-core.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "An X11-based distribution with the Enlightenment Window Manager"
DEPENDS = "${MACHINE_TASK_PROVIDER} \
- xserver-kdrive \
+ ${XSERVER} \
task-e-x11-core"
-IMAGE_INSTALL = "${MACHINE_TASK_PROVIDER} task-e-x11-core xserver-kdrive-fbdev glibc-charmap-utf-8 glibc-localedata-i18n"
+IMAGE_INSTALL = "${MACHINE_TASK_PROVIDER} task-e-x11-core ${XSERVER} glibc-charmap-utf-8 glibc-localedata-i18n"
IMAGE_LINGUAS = ""
inherit image