aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/fso-illume-image.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/images/fso-illume-image.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/images/fso-illume-image.bb')
-rw-r--r--recipes/images/fso-illume-image.bb83
1 files changed, 83 insertions, 0 deletions
diff --git a/recipes/images/fso-illume-image.bb b/recipes/images/fso-illume-image.bb
new file mode 100644
index 0000000000..189c8cba69
--- /dev/null
+++ b/recipes/images/fso-illume-image.bb
@@ -0,0 +1,83 @@
+#------------------------------------------------------
+# FSO-compliant Illume Image Recipe
+#------------------------------------------------------
+
+require fso-image.inc
+
+PV = "1.1"
+PR = "r1"
+
+# no languages for now
+IMAGE_LINGUAS = ""
+
+BASE_INSTALL = "\
+ task-base \
+"
+
+ILLUME_THEME = "illume-theme-fso"
+
+X_INSTALL = "\
+ task-x11-illume \
+ task-fonts-truetype-core \
+"
+
+X_INSTALL_append_om-gta02 = "\
+ task-fonts-truetype-chinese \
+ task-fonts-truetype-japanese \
+"
+
+# tools
+TOOLS_INSTALL = "\
+ task-cli-tools \
+ task-cli-tools-python \
+"
+
+# audio
+AUDIO_INSTALL = "\
+ alsa-oss \
+ alsa-state \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ gst-meta-audio \
+ gst-plugin-modplug \
+ gst-plugin-sid \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)} \
+ fso-sounds \
+"
+
+GTK_INSTALL = "\
+ tango-icon-theme \
+ vala-terminal \
+ gpe-scap \
+"
+
+# FIXME these should rather be part of alsa-state,
+# once Om stabilizes them...
+AUDIO_INSTALL_append_om-gta01 = "\
+ openmoko-alsa-scenarios \
+"
+AUDIO_INSTALL_append_om-gta02 = "\
+ openmoko-alsa-scenarios \
+"
+
+# python
+PYTHON_INSTALL = "\
+ python-codecs \
+ python-gst \
+"
+
+# fso
+FSO_INSTALL = "\
+ task-fso-compliance \
+"
+
+IMAGE_INSTALL = "\
+ ${BASE_INSTALL} \
+ ${X_INSTALL} \
+ ${GTK_INSTALL} \
+ ${GAMES_INSTALL} \
+ ${AUDIO_INSTALL} \
+ ${TOOLS_INSTALL} \
+ ${PYTHON_INSTALL} \
+ ${FSO_INSTALL} \
+"