summaryrefslogtreecommitdiffstats
path: root/recipes/images/gpe-image.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/images/gpe-image.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/images/gpe-image.bb')
-rw-r--r--recipes/images/gpe-image.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/images/gpe-image.bb b/recipes/images/gpe-image.bb
new file mode 100644
index 0000000000..8cbe8a8571
--- /dev/null
+++ b/recipes/images/gpe-image.bb
@@ -0,0 +1,40 @@
+GPE_EXTRA_THEMES = "gpe-theme-industrial"
+
+GPE_EXTRA_INSTALL_none = ""
+GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
+GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
+
+GUI_MACHINE_CLASS ?= "none"
+GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
+
+#ship more stuff with devices with >16MB of flash
+GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
+ task-gpe-connectivity \
+ gpe-theme-clearlooks \
+ figment \
+",d)}'
+
+GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+DEPENDS = "${MACHINE_TASK_PROVIDER} \
+ task-gpe-base \
+ task-gpe-apps \
+ task-gpe-pim \
+ task-gpe-settings \
+ task-gpe-games \
+ virtual/xserver"
+
+IMAGE_INSTALL = "\
+ ${MACHINE_TASK_PROVIDER} \
+ task-gpe-base \
+ task-gpe-pim \
+ task-gpe-settings \
+ task-gpe-apps \
+ ${XSERVER} \
+ ${GPE_EXTRA_INSTALL}"
+
+#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+
+inherit image