summaryrefslogtreecommitdiffstats
path: root/recipes/images/micro-image.bb
diff options
context:
space:
mode:
authorMartin Lund <mgl@doredevelopment.dk>2009-04-30 13:15:36 +0200
committerMartin Lund <mgl@doredevelopment.dk>2009-04-30 13:15:36 +0200
commit7785ce4baefbb17b2fd2f8ebe64e8a91a7fade32 (patch)
treefffbc1a48f7bbda70c0130d5d8eb7f25bcc793f0 /recipes/images/micro-image.bb
downloadopenembedded-7785ce4baefbb17b2fd2f8ebe64e8a91a7fade32.tar.gz
Initial add of micro linux dist
Diffstat (limited to 'recipes/images/micro-image.bb')
-rw-r--r--recipes/images/micro-image.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/images/micro-image.bb b/recipes/images/micro-image.bb
new file mode 100644
index 0000000000..b31365d1d1
--- /dev/null
+++ b/recipes/images/micro-image.bb
@@ -0,0 +1,34 @@
+# micro-image
+#
+# Image configuration for the OE Micro Linux Distribuion (micro, micro-uclibc)
+#
+# This image basically consists of: libc, busybox, udev, sysv init, and a few
+# init scripts for running up the system.
+#
+# It is truely tiny and should build with most architectures/machines.
+#
+# The image is tested to build and run succesfully with the following machines:
+#
+# * at91sam9263ek (jffs2 image size ~ 1 MB, uclibc)
+# * x86
+#
+# Maintainer: Martin Lund <mgl@doredevelopment.dk>
+#
+
+# Install basic files only
+IMAGE_INSTALL = "base-files base-passwd"
+IMAGE_LINGUAS = ""
+
+# Use busybox as login manager
+IMAGE_LOGIN_MANAGER = "busybox"
+
+# Include minimum init and init scripts
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
+IMAGE_INITSCRIPTS = ""
+
+# Do not install target package management system
+ONLINE_PACKAGE_MANAGEMENT = "none"
+
+inherit image
+