summaryrefslogtreecommitdiffstats
path: root/recipes/images/nylon-image-base.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/images/nylon-image-base.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/images/nylon-image-base.bb')
-rw-r--r--recipes/images/nylon-image-base.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/images/nylon-image-base.bb b/recipes/images/nylon-image-base.bb
new file mode 100644
index 0000000000..27dc165800
--- /dev/null
+++ b/recipes/images/nylon-image-base.bb
@@ -0,0 +1,28 @@
+inherit image
+inherit nylon-image
+
+export IMAGE_BASENAME = "nylon-base"
+
+NYLON_BASE = "base-files base-passwd bash busybox \
+ ipkg initscripts less \
+ mtd-utils \
+ nano ncurses netbase \
+ openssh sysvinit \
+ tzdata tinylogin udev"
+
+DEPENDS += "virtual/kernel less nano"
+IMAGE_INSTALL = "kernel less nano elvis-tiny \
+ ${NYLON_BASE} ${BOOTSTRAP_EXTRA_RDEPENDS}"
+
+## kernel 2.4 ##
+RDEPENDS_append_mtx-1 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+RDEPENDS_append_mtx-2 = " modutils modutils-initscripts modutils-depmod modutils-modinfo"
+## kernel 2.6 ##
+RDEPENDS_append_mtx-3 = " module-init-tools udev"
+RDEPENDS_append_mtx-3a = " module-init-tools"
+
+IMAGE_LINGUAS = ""
+
+# we dont need the kernel in the image
+ROOTFS_POSTPROCESS_COMMAND = "rm -f ${IMAGE_ROOTFS}/tmp/*Image*"
+# needed?? the above line is the same as in classes/nylon-image.bbclass