aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/slugos-image.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-30 16:29:53 -0500
committerMike Westerhof <mwester@dls.net>2009-04-30 16:29:53 -0500
commit74efae1b1ab7b6cf37b08de1c0eb1e2c564d2b3c (patch)
treed182aa4deb56492e8755fa3d493fa86e63d375c8 /recipes/images/slugos-image.bb
parent9823dcf3aa8783b0d1daa7ce363aaf01c318bea0 (diff)
downloadopenembedded-74efae1b1ab7b6cf37b08de1c0eb1e2c564d2b3c.tar.gz
SlugOS: slugos-image.bb, initscripts-slugos_1.0.bb - remove devfs support
Remove devfs startup scripts, and revert to the standard OE means to initially populate the /dev directory. This has the side-effect of fixing the empty /dev dir problem when extracting the tar.gz image.
Diffstat (limited to 'recipes/images/slugos-image.bb')
-rw-r--r--recipes/images/slugos-image.bb12
1 files changed, 1 insertions, 11 deletions
diff --git a/recipes/images/slugos-image.bb b/recipes/images/slugos-image.bb
index 56abc3d39f..24ba91552f 100644
--- a/recipes/images/slugos-image.bb
+++ b/recipes/images/slugos-image.bb
@@ -13,23 +13,13 @@ COMPATIBLE_MACHINE = "nslu2|ixp4xx"
IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
IMAGE_FSTYPES = "jffs2 tar.gz"
-EXTRA_IMAGECMD_jffs2 += " -D ${SLUGOS_DEVICE_TABLE}"
+IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
IMAGE_LINGUAS = ""
-# Setting USE_DEVFS prevents *any* entries being created initially
-# in /dev
-USE_DEVFS = "1"
-
-# This is passed to the image command to build the correct /dev
-# directory (because only the image program can make actual
-# dev entries!)
-SLUGOS_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-slugos.txt')}"
-
# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
# kernel image is removed from the root file system to recover the space used -
# SlugOS is assumed to boot from a separate kernel image in flash (not in the
# root file system), if this is not the case the following must not be done!
IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
-IMAGE_PREPROCESS_COMMAND += "install -c -m 644 ${SLUGOS_DEVICE_TABLE} ${IMAGE_ROOTFS}/etc/device_table;"
inherit image nslu2-image