aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/ti-demo-x11-image.bb
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2009-10-29 17:50:43 -0500
committerKoen Kooi <koen@openembedded.org>2009-11-02 13:40:10 +0100
commit549bda4de616c0f29665735912f350de694fcdd5 (patch)
treec43e81c1284df11fb8677a901fb5f2cca7203fbe /recipes/images/ti-demo-x11-image.bb
parent5a9d128fc9c4ff5f731ede82502ad80b0ccb37ee (diff)
downloadopenembedded-549bda4de616c0f29665735912f350de694fcdd5.tar.gz
ti-demo-x11-image: add task and image for build x11 based demo image for TI platforms.
Diffstat (limited to 'recipes/images/ti-demo-x11-image.bb')
-rw-r--r--recipes/images/ti-demo-x11-image.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/images/ti-demo-x11-image.bb b/recipes/images/ti-demo-x11-image.bb
new file mode 100644
index 0000000000..e37d183be9
--- /dev/null
+++ b/recipes/images/ti-demo-x11-image.bb
@@ -0,0 +1,31 @@
+# TI X11 demo image
+
+IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
+
+export IMAGE_BASENAME = "ti-demo-x11-image"
+
+DEPENDS = "task-base"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-demo-x11 \
+ ${SPLASH} \
+ "
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image
+