aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorCarsten Haitzler (Rasterman <raster@rasterman.com>2009-04-17 15:44:58 +1000
committerCarsten Haitzler (Rasterman) <raster@rasterman.com>2009-04-17 15:48:45 +1000
commit212e36417ae27e1be11147168b6f5cdfd1c5eda9 (patch)
tree00892cc3bca94534140f1e44ab98b4e58587410c /recipes/images
parentd92391844e4454ba9ea3af5b4273721496511ebb (diff)
downloadopenembedded-212e36417ae27e1be11147168b6f5cdfd1c5eda9.tar.gz
angstrom, exquisite, psplash, opkg, angsrtom-images, sysvinit: abstract splash
this abstracts psplash to be generic. now as long as something provides a splashfuncs file that sysvinit (and other scripts) can source, and all the approproate init hooks to start the splash etc. you can use psplash, exquisitie, usplash or anything that tickles your fancy. this moves splash toa ${SPLASH} variable to include in your image (or override). the default in angstrom is psplash - unless you override it. opkg also runs a configure script that cna take forever - and so this speically sends off some splash commands (if there) to let you know the systme is alive and working (but just busy). this is one commit as if this breaks things you either want to fix the minor break or totally revert the whole patch. i hope it didn't break anything.
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/beagleboard-demo-image.bb1
-rw-r--r--recipes/images/bootmanager-image.bb2
-rw-r--r--recipes/images/gateway-image.bb1
-rw-r--r--recipes/images/illume-image.bb7
-rw-r--r--recipes/images/minimal-gpe-image.bb1
-rw-r--r--recipes/images/minimal-image.bb1
-rw-r--r--recipes/images/sdr-image.bb1
-rw-r--r--recipes/images/sugar-image.bb1
-rw-r--r--recipes/images/udumpty-image.bb1
-rw-r--r--recipes/images/x11-gpe-image.bb1
-rw-r--r--recipes/images/x11-gpe-java-image.bb1
-rw-r--r--recipes/images/x11-image.bb1
-rw-r--r--recipes/images/x11-office-image.bb1
-rw-r--r--recipes/images/x11-pimlico-image.bb1
14 files changed, 17 insertions, 4 deletions
diff --git a/recipes/images/beagleboard-demo-image.bb b/recipes/images/beagleboard-demo-image.bb
index 4007daec25..7d0e408b73 100644
--- a/recipes/images/beagleboard-demo-image.bb
+++ b/recipes/images/beagleboard-demo-image.bb
@@ -18,6 +18,7 @@ IMAGE_INSTALL = "\
${XSERVER} \
${ANGSTROM_EXTRA_INSTALL} \
task-beagleboard-demo \
+ ${SPLASH} \
"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/bootmanager-image.bb b/recipes/images/bootmanager-image.bb
index d829590188..1f8c3273f6 100644
--- a/recipes/images/bootmanager-image.bb
+++ b/recipes/images/bootmanager-image.bb
@@ -1,7 +1,7 @@
#Angstrom bootmanager image
DEPENDS = "task-angstrom"
-IMAGE_INSTALL = "angstrom-base-depends angstrom-bootmanager"
+IMAGE_INSTALL = "angstrom-base-depends angstrom-bootmanager ${SPLASH}"
export IMAGE_BASENAME = "bootmanager-image"
diff --git a/recipes/images/gateway-image.bb b/recipes/images/gateway-image.bb
index ee9d1d97fc..8df21bcbeb 100644
--- a/recipes/images/gateway-image.bb
+++ b/recipes/images/gateway-image.bb
@@ -11,6 +11,7 @@ IMAGE_INSTALL = "task-boot \
dnsmasq \
# vsftpd \
angstrom-version \
+ ${SPLASH} \
"
export IMAGE_BASENAME = "gateway-image"
diff --git a/recipes/images/illume-image.bb b/recipes/images/illume-image.bb
index 9c2b1befed..3ab006ae9c 100644
--- a/recipes/images/illume-image.bb
+++ b/recipes/images/illume-image.bb
@@ -4,6 +4,9 @@
IMAGE_LINGUAS = "en-us de-de fr-fr pt-br ca-es zh-cn zh-tw bg-bg cs-cz da-dk nl-nl fi-fi hu-hu it-it ja-jp ko-kr nb-no pl-pl ru-ru sk-sk sl-si es-ar sv-se"
+# use exquisite splash
+SPLASH = "exquisite exquisite-themes exquisite-theme-illume"
+
# getting the base system up
BASE_INSTALL = "\
angstrom-libc-fixup-hack \
@@ -17,9 +20,6 @@ BASE_INSTALL = "\
pointercal \
tslib-conf \
# prelink \
-# exquisite \
-# exquisite-themes \
-# exquisite-theme-illume \
# rsync \
# screen \
# fbset \
@@ -154,6 +154,7 @@ IMAGE_INSTALL = "\
# ${ZHONE_INSTALL} \
${APPS_INSTALL} \
${DEV_INSTALL} \
+ ${SPLASH} \
"
inherit image
diff --git a/recipes/images/minimal-gpe-image.bb b/recipes/images/minimal-gpe-image.bb
index 5dd08f6e23..d71f9dee19 100644
--- a/recipes/images/minimal-gpe-image.bb
+++ b/recipes/images/minimal-gpe-image.bb
@@ -17,6 +17,7 @@ IMAGE_INSTALL = "\
gpe-terminal \
angstrom-feed-configs \
opkg-nogpg opkg-collateral \
+ ${SPLASH} \
"
#zap root password for release images
diff --git a/recipes/images/minimal-image.bb b/recipes/images/minimal-image.bb
index e1635dcdf7..0acb5f1ad1 100644
--- a/recipes/images/minimal-image.bb
+++ b/recipes/images/minimal-image.bb
@@ -11,6 +11,7 @@ IMAGE_INSTALL = "task-boot \
${DISTRO_SSH_DAEMON} \
${ANGSTROM_EXTRA_INSTALL} \
angstrom-version \
+ ${SPLASH} \
"
export IMAGE_BASENAME = "minimalist-image"
diff --git a/recipes/images/sdr-image.bb b/recipes/images/sdr-image.bb
index 9e0f4e6a41..8338a57338 100644
--- a/recipes/images/sdr-image.bb
+++ b/recipes/images/sdr-image.bb
@@ -43,6 +43,7 @@ IMAGE_INSTALL = " task-base-extended \
uucp picocom \
angstrom-zeroconf-audio avahi-utils \
${ANGSTROM_EXTRA_INSTALL} \
+ ${SPLASH} \
"
inherit image
diff --git a/recipes/images/sugar-image.bb b/recipes/images/sugar-image.bb
index 4dbc1671af..2787f99e00 100644
--- a/recipes/images/sugar-image.bb
+++ b/recipes/images/sugar-image.bb
@@ -10,6 +10,7 @@ IMAGE_INSTALL = "\
angstrom-gpe-task-base \
angstrom-gpe-task-settings \
sugar-sucrose \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/udumpty-image.bb b/recipes/images/udumpty-image.bb
index c55381ed30..e581a8edab 100644
--- a/recipes/images/udumpty-image.bb
+++ b/recipes/images/udumpty-image.bb
@@ -43,6 +43,7 @@ IMAGE_INSTALL = "\
gnome-control-center \
gnome-settings-daemon \
gnome-session \
+ ${SPLASH} \
"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-gpe-image.bb b/recipes/images/x11-gpe-image.bb
index 7b272f60a1..03c9761663 100644
--- a/recipes/images/x11-gpe-image.bb
+++ b/recipes/images/x11-gpe-image.bb
@@ -16,6 +16,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-gpe-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
diff --git a/recipes/images/x11-gpe-java-image.bb b/recipes/images/x11-gpe-java-image.bb
index fcc022c7a0..b8904e303c 100644
--- a/recipes/images/x11-gpe-java-image.bb
+++ b/recipes/images/x11-gpe-java-image.bb
@@ -18,6 +18,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-gpe-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-image.bb b/recipes/images/x11-image.bb
index 093e0c5b6d..7c632e3a96 100644
--- a/recipes/images/x11-image.bb
+++ b/recipes/images/x11-image.bb
@@ -12,6 +12,7 @@ IMAGE_INSTALL = "\
angstrom-x11-base-depends \
angstrom-gpe-task-base \
angstrom-gpe-task-settings \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-office-image.bb b/recipes/images/x11-office-image.bb
index 48799d8998..66cc762d93 100644
--- a/recipes/images/x11-office-image.bb
+++ b/recipes/images/x11-office-image.bb
@@ -21,6 +21,7 @@ IMAGE_INSTALL = "\
claws-mail claws-mail claws-plugin-mailmbox claws-plugin-rssyl \
midori minimo \
gphoto2 \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
diff --git a/recipes/images/x11-pimlico-image.bb b/recipes/images/x11-pimlico-image.bb
index 79dcacce6e..e16eb51043 100644
--- a/recipes/images/x11-pimlico-image.bb
+++ b/recipes/images/x11-pimlico-image.bb
@@ -16,6 +16,7 @@ IMAGE_INSTALL = "\
kernel-modules \
hal \
angstrom-ohand-task-pim \
+ ${SPLASH} \
${ANGSTROM_EXTRA_INSTALL}"
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"