aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-30 16:35:05 -0500
committerMike Westerhof <mwester@dls.net>2009-04-30 16:36:35 -0500
commite40bd5bec56b83aa39b1f5a3a62e17c6d1ddf60f (patch)
tree0780a037341bd1cf945ee5c2b5e976a736e4aa3c /recipes/images
parent87fbf88f7e448eb9381f7fc0551dd386616c6f9b (diff)
downloadopenembedded-e40bd5bec56b83aa39b1f5a3a62e17c6d1ddf60f.tar.gz
SlugOS: refactor slugos images and tasks to support a standard and extended image.
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/slugos-extd-image.bb17
-rw-r--r--recipes/images/slugos-image.bb21
-rw-r--r--recipes/images/slugos-image.inc24
3 files changed, 45 insertions, 17 deletions
diff --git a/recipes/images/slugos-extd-image.bb b/recipes/images/slugos-extd-image.bb
new file mode 100644
index 0000000000..fa027803a3
--- /dev/null
+++ b/recipes/images/slugos-extd-image.bb
@@ -0,0 +1,17 @@
+# This describes the SlugOS Extended image, which includes everything
+# that is in the standard NSLU2 image, with a few extra drivers. This
+# image is usually used with other IXP4xx machines, such as the D-Link
+# DSM-G600A and the NAS100D
+
+DESCRIPTION = "SlugOS Extended image"
+
+PR = "r1"
+
+require slugos-image.inc
+
+IMAGE_NAME = "${IMAGE_BASENAME}-extd-${DISTRO_VERSION}"
+DEPENDS += "task-slugos-extd"
+IMAGE_INSTALL += "task-slugos-extd"
+
+# Todo: fix these image creation tools
+#inherit dsmg600-image nas100d-image
diff --git a/recipes/images/slugos-image.bb b/recipes/images/slugos-image.bb
index 24ba91552f..24e83f0b66 100644
--- a/recipes/images/slugos-image.bb
+++ b/recipes/images/slugos-image.bb
@@ -2,24 +2,11 @@
# called 'slugos-image.bb' the distro specific configuration is
# done in conf/distro/${DISTRO}.conf (which should always include
# conf/distro/slugos.conf to get the standard settings).
-#
-DESCRIPTION = "Generic SlugOS image"
-HOMEPAGE = "http://www.nslu2-linux.org"
-
-DEPENDS = "task-slugos"
-IMAGE_INSTALL = "task-slugos"
-COMPATIBLE_MACHINE = "nslu2|ixp4xx"
+DESCRIPTION = "Generic SlugOS image"
-IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
-IMAGE_FSTYPES = "jffs2 tar.gz"
-IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
-IMAGE_LINGUAS = ""
+PR = "r1"
-# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
-# kernel image is removed from the root file system to recover the space used -
-# SlugOS is assumed to boot from a separate kernel image in flash (not in the
-# root file system), if this is not the case the following must not be done!
-IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
+require slugos-image.inc
-inherit image nslu2-image
+inherit nslu2-image
diff --git a/recipes/images/slugos-image.inc b/recipes/images/slugos-image.inc
new file mode 100644
index 0000000000..725d1fac61
--- /dev/null
+++ b/recipes/images/slugos-image.inc
@@ -0,0 +1,24 @@
+# This describes a generic SlugOS image, even though the bb file is
+# called 'slugos-image.bb' the distro specific configuration is
+# done in conf/distro/${DISTRO}.conf (which should always include
+# conf/distro/slugos.conf to get the standard settings).
+
+HOMEPAGE = "http://www.nslu2-linux.org"
+
+DEPENDS = "task-slugos"
+IMAGE_INSTALL = "task-slugos"
+
+COMPATIBLE_MACHINE = "nslu2|ixp4xx|sheevaplug"
+
+IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
+IMAGE_FSTYPES = "jffs2 tar.gz"
+IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
+IMAGE_LINGUAS = ""
+
+# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
+# kernel image is removed from the root file system to recover the space used -
+# SlugOS is assumed to boot from a separate kernel image in flash (not in the
+# root file system), if this is not the case the following must not be done!
+IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
+
+inherit image