aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-26 16:36:59 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-26 22:16:57 +0100
commitf12dd3b7438ec4672be5b4ada3bcd79afbcba137 (patch)
treeeb5ec48ddf7626e4ba910c853ce1b18665b1838b /recipes/images
parentb6e82ec5da43b07d96e6fe2ba251e6783004a344 (diff)
downloadopenembedded-f12dd3b7438ec4672be5b4ada3bcd79afbcba137.tar.gz
shr-image: add all needed deps to task-shr-minimal, remove /boot from jffs2/ubi/ubifs
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/shr-image.bb14
-rw-r--r--recipes/images/shr-image.inc17
2 files changed, 6 insertions, 25 deletions
diff --git a/recipes/images/shr-image.bb b/recipes/images/shr-image.bb
index 23f4f64e4c..3d72ca0b53 100644
--- a/recipes/images/shr-image.bb
+++ b/recipes/images/shr-image.bb
@@ -16,17 +16,3 @@ IMAGE_INSTALL += "\
task-shr-gtk \
task-shr-cli \
"
-
-# perform some SHR convenience tweaks to the rootfs
-shr_rootfs_postprocess_append() {
- curdir=$PWD
- cd ${IMAGE_ROOTFS}
-
-
- #Replace desktop files
- echo "Icon=pidgin.png" >> ./usr/share/applications/pidgin.desktop
- sed -i "s/^X-Icon-path.*$//g" ./usr/share/applications/vagalume.desktop
-
- cd $curdir
-}
-
diff --git a/recipes/images/shr-image.inc b/recipes/images/shr-image.inc
index f06d86b429..9408091c8d 100644
--- a/recipes/images/shr-image.inc
+++ b/recipes/images/shr-image.inc
@@ -3,14 +3,12 @@
#------------------------------------------------------
PV = "2.0"
-PR = "r11"
+PR = "r12"
DEPENDS += "task-shr-minimal"
RDEPENDS += "\
- ${MACHINE_TASK_PROVIDER} \
- task-base \
task-shr-minimal-base \
task-shr-minimal-cli \
task-shr-minimal-fso \
@@ -18,23 +16,15 @@ RDEPENDS += "\
task-shr-minimal-audio \
task-shr-minimal-gtk \
task-shr-minimal-x \
- task-x11-illume \
- task-fso2-compliance \
- task-fonts-truetype-core \
"
IMAGE_INSTALL += "\
- ${MACHINE_TASK_PROVIDER} \
- task-base \
task-shr-minimal-base \
task-shr-minimal-cli \
task-shr-minimal-apps \
task-shr-minimal-audio \
task-shr-minimal-gtk \
task-shr-minimal-x \
- task-x11-illume \
- task-fso2-compliance \
- task-fonts-truetype-core \
"
inherit image
@@ -140,6 +130,11 @@ shr_rootfs_gta01_postprocess() {
cd $curdir
}
+# We don't want /boot directory in jffs2/ubi/ubifs images
+IMAGE_CMD_jffs2 = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && mkfs.jffs2 -x lzo --root=${IMAGE_ROOTFS} --faketime --output=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 ${EXTRA_IMAGECMD} && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+IMAGE_CMD_ubi = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && echo \[ubifs\] > ubinize.cfg ; echo mode=ubi >> ubinize.cfg ; echo image=${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs >> ubinize.cfg ; echo vol_id=0 >> ubinize.cfg ; echo vol_type=dynamic >> ubinize.cfg ; echo vol_name=${UBI_VOLNAME} >> ubinize.cfg ; echo vol_flags=autoresize >> ubinize.cfg;mkfs.ubifs -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubifs ${MKUBIFS_ARGS} && ubinize -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.ubi ${UBINIZE_ARGS} ubinize.cfg && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+IMAGE_CMD_ubifs = "mv ${IMAGE_ROOTFS}/boot ${IMAGE_ROOTFS}-boot && mkfs.ubifs -r ${IMAGE_ROOTFS} -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.ubifs.img ${MKUBIFS_ARGS} && mv ${IMAGE_ROOTFS}-boot ${IMAGE_ROOTFS}/boot"
+
ROOTFS_POSTPROCESS_COMMAND += " shr_rootfs_postprocess"
ROOTFS_POSTPROCESS_COMMAND_append_om-gta02 = ";shr_rootfs_gta02_postprocess"