aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-05-03 14:18:37 +0200
committerLeon Woestenberg <leon@sidebranch.com>2009-05-03 14:18:37 +0200
commitd260584374e28a34d103011efa4cf773f98a5c7c (patch)
tree5bd19f3c09f00d2fc77acba490af59e5323edfb2 /recipes/images
parent55e8673a82c909599fd66acbfa377992c33501f0 (diff)
parent7785ce4baefbb17b2fd2f8ebe64e8a91a7fade32 (diff)
downloadopenembedded-d260584374e28a34d103011efa4cf773f98a5c7c.tar.gz
Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/micro-image.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/images/micro-image.bb b/recipes/images/micro-image.bb
new file mode 100644
index 0000000000..b31365d1d1
--- /dev/null
+++ b/recipes/images/micro-image.bb
@@ -0,0 +1,34 @@
+# micro-image
+#
+# Image configuration for the OE Micro Linux Distribuion (micro, micro-uclibc)
+#
+# This image basically consists of: libc, busybox, udev, sysv init, and a few
+# init scripts for running up the system.
+#
+# It is truely tiny and should build with most architectures/machines.
+#
+# The image is tested to build and run succesfully with the following machines:
+#
+# * at91sam9263ek (jffs2 image size ~ 1 MB, uclibc)
+# * x86
+#
+# Maintainer: Martin Lund <mgl@doredevelopment.dk>
+#
+
+# Install basic files only
+IMAGE_INSTALL = "base-files base-passwd"
+IMAGE_LINGUAS = ""
+
+# Use busybox as login manager
+IMAGE_LOGIN_MANAGER = "busybox"
+
+# Include minimum init and init scripts
+IMAGE_DEV_MANAGER = "udev"
+IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
+IMAGE_INITSCRIPTS = ""
+
+# Do not install target package management system
+ONLINE_PACKAGE_MANAGEMENT = "none"
+
+inherit image
+