aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-03 12:43:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-03 12:43:06 +0100
commita3bc04cdffd1ee77c73835b51c8d12120010fba8 (patch)
treebce6612ca5bcf758b6bda3955dfc362372462a7d /recipes/images
parent3262724e9c338d5ebfe8c09042e639e71b74f4c6 (diff)
parent55331de7302867eda6b4af59907ec1ec243f099b (diff)
downloadopenembedded-a3bc04cdffd1ee77c73835b51c8d12120010fba8.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/merge
Conflicts: conf/checksums.ini
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/ti-demo-x11-image.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/images/ti-demo-x11-image.bb b/recipes/images/ti-demo-x11-image.bb
new file mode 100644
index 0000000000..e37d183be9
--- /dev/null
+++ b/recipes/images/ti-demo-x11-image.bb
@@ -0,0 +1,31 @@
+# TI X11 demo image
+
+IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+SPLASH = "exquisite exquisite-themes exquisite-theme-angstrom"
+
+export IMAGE_BASENAME = "ti-demo-x11-image"
+
+DEPENDS = "task-base"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ task-demo-x11 \
+ ${SPLASH} \
+ "
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image
+