aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-14 22:25:44 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-02-14 22:25:44 +0100
commit9c91c2996218e34034ad45ef4c353e521c32c385 (patch)
treed90cbe7aa7de911e43efdf246a69c95e2391936c /recipes/images
parentc0847c8d15367062ea231b5aa8ca93eb9190be0e (diff)
downloadopenembedded-9c91c2996218e34034ad45ef4c353e521c32c385.tar.gz
xfce46-image added some missing packages
added xinit and dbus-x11 as these are missing and required to start Xorg Maybe there is a better place for this, but for now this will do (and if someone knows a better place, feel free to modify) Also added Xorg extension packages as they are needed for KMS (which in turn is used by the latest intel driver) Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/xfce46-image.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes/images/xfce46-image.bb b/recipes/images/xfce46-image.bb
index 8f8e240f3f..25282bb745 100644
--- a/recipes/images/xfce46-image.bb
+++ b/recipes/images/xfce46-image.bb
@@ -1,3 +1,5 @@
+PR = "r1"
+
export IMAGE_BASENAME = "xfce46-image"
XSERVER ?= "xserver-xorg \
@@ -7,8 +9,11 @@ XSERVER ?= "xserver-xorg \
xf86-input-keyboard \
"
-DEPENDS = "virtual/xserver ${MACHINE_TASK_PROVIDER} task-xfce46-base task-xfce46-extras"
+DEPENDS = "virtual/xserver ${MACHINE_TASK_PROVIDER} task-xfce46-base task-xfce46-extras \
+ xinit dbus"
-IMAGE_INSTALL = "${XSERVER} ${MACHINE_TASK_PROVIDER} task-xfce46-base task-xfce46-extras"
+IMAGE_INSTALL = "${XSERVER} ${MACHINE_TASK_PROVIDER} task-xfce46-base task-xfce46-extras \
+ xinit dbus-x11 xserver-xorg-extension-dri server-xorg-extension-dri2 \
+ xserver-xorg-extension-glx"
inherit image