aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/imlib
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/imlib
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/imlib')
-rw-r--r--recipes/imlib/files/configure.patch31
-rw-r--r--recipes/imlib/imlib_1.9.15.bb20
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/imlib/files/configure.patch b/recipes/imlib/files/configure.patch
new file mode 100644
index 0000000000..90879c15ee
--- /dev/null
+++ b/recipes/imlib/files/configure.patch
@@ -0,0 +1,31 @@
+--- /tmp/configure.in 2006-09-02 12:44:16.000000000 +0200
++++ imlib-1.9.15/configure.in 2006-09-02 12:44:22.975780000 +0200
+@@ -43,19 +43,6 @@
+ oCFLAGS="$CFLAGS"
+ LIBS="$LIBS `glib-config --libs gmodule`"
+ CFLAGS="$CFLAGS `glib-config --cflags gmodule`"
+- AC_TRY_RUN([
+-#include <glib.h>
+-#include <gmodule.h>
+-main ()
+-{
+- if (g_module_supported ())
+- exit (0);
+- else
+- exit (1);
+-}
+-], dynworks=true)
+- LIBS="$oLIBS"
+- CFLAGS="$oCFLAGS"
+ fi
+
+ dnl Now we check to see if our libtool supports shared lib deps
+@@ -141,7 +128,7 @@
+ fi
+ AC_SUBST(GX_LIBS)
+
+-CPPFLAGS="$CPPFLAGS -I$includedir -I$prefix/include"
++CPPFLAGS="$CPPFLAGS"
+
+ SUPPORT_LIBS=""
+
diff --git a/recipes/imlib/imlib_1.9.15.bb b/recipes/imlib/imlib_1.9.15.bb
new file mode 100644
index 0000000000..da96736958
--- /dev/null
+++ b/recipes/imlib/imlib_1.9.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Image loading library"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+-1.2 jpeg tiff libpng libungif"
+
+inherit gnome binconfig
+
+SRC_URI += "file://configure.patch;patch=1"
+
+EXTRA_OECONF = " --enable-modules \
+ --disable-gtktest \
+ ac_cv_dynworks=true \
+ "
+
+do_stage() {
+ install -m 644 Imlib/*.h ${STAGING_INCDIR}
+ install -m 644 gdk_imlib/*.h ${STAGING_INCDIR}
+ oe_libinstall -a -so -C Imlib libImlib ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C gdk_imlib libgdk_imlib ${STAGING_LIBDIR}
+}
+