aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/inetutils/inetutils_1.5.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/inetutils/inetutils_1.5.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/inetutils/inetutils_1.5.bb')
-rw-r--r--recipes/inetutils/inetutils_1.5.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/inetutils/inetutils_1.5.bb b/recipes/inetutils/inetutils_1.5.bb
new file mode 100644
index 0000000000..17f202cfbe
--- /dev/null
+++ b/recipes/inetutils/inetutils_1.5.bb
@@ -0,0 +1,39 @@
+SECTION = "libs"
+DEPENDS = "ncurses"
+LICENSE = "GPL"
+DESCRIPTION = "The GNU inetutils are a collection of common \
+networking utilities and servers including ftp, ftpd, rcp, \
+rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
+talkd, telnet, telnetd, tftp, tftpd, and uucpd."
+
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \
+"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR}"
+
+do_configure_prepend () {
+ rm -f ${S}/glob/configure*
+}
+
+do_install () {
+ autotools_do_install
+ mv ${D}${bindir}/tftp ${D}${bindir}/tftp.${PN}
+ mv ${D}${bindir}/telnet ${D}${bindir}/telnet.${PN}
+ mv ${D}${bindir}/logger ${D}${bindir}/logger.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/tftp tftp tftp.${PN} 100
+ update-alternatives --install ${bindir}/telnet telnet telnet.${PN} 100
+ update-alternatives --install ${bindir}/logger logger logger.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove tftp tftp.${PN}
+ update-alternatives --remove telnet telnet.${PN}
+ update-alternatives --remove logger logger.${PN}
+}