aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initscripts
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/initscripts
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/initscripts')
-rw-r--r--recipes/initscripts/initscripts-openmoko_1.0.bb2
-rw-r--r--recipes/initscripts/initscripts-slugos_1.0.bb2
-rw-r--r--recipes/initscripts/initscripts_1.0.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/initscripts/initscripts-openmoko_1.0.bb b/recipes/initscripts/initscripts-openmoko_1.0.bb
index d6d233b535..d928468249 100644
--- a/recipes/initscripts/initscripts-openmoko_1.0.bb
+++ b/recipes/initscripts/initscripts-openmoko_1.0.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = ""
-RDEPENDS = ""
+RDEPENDS_${PN} = ""
RCONFLICTS_${PN} = "initscripts"
diff --git a/recipes/initscripts/initscripts-slugos_1.0.bb b/recipes/initscripts/initscripts-slugos_1.0.bb
index 43153c060d..b79351445a 100644
--- a/recipes/initscripts/initscripts-slugos_1.0.bb
+++ b/recipes/initscripts/initscripts-slugos_1.0.bb
@@ -12,7 +12,7 @@ RCONFLICTS = "initscripts"
# the below lines serve to remove the dependency on the full makedevs package,
# as well as adding the dependency for the update-rc.d package.
DEPENDS = "update-rc.d-native"
-RDEPENDS = "update-rc.d"
+RDEPENDS_${PN} = "update-rc.d"
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
diff --git a/recipes/initscripts/initscripts_1.0.bb b/recipes/initscripts/initscripts_1.0.bb
index 588375d1b7..601622f241 100644
--- a/recipes/initscripts/initscripts_1.0.bb
+++ b/recipes/initscripts/initscripts_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "SysV init scripts"
SECTION = "base"
PRIORITY = "required"
DEPENDS = "makedevs"
-RDEPENDS = "makedevs"
+RDEPENDS_${PN} = "makedevs"
LICENSE = "GPL"
PR = "r120"