aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/inputpipe
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/inputpipe
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/inputpipe')
-rw-r--r--recipes/inputpipe/inputpipe_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/inputpipe/inputpipe_svn.bb b/recipes/inputpipe/inputpipe_svn.bb
new file mode 100644
index 0000000000..c6e28c3e79
--- /dev/null
+++ b/recipes/inputpipe/inputpipe_svn.bb
@@ -0,0 +1,24 @@
+SECTION = "base"
+PRIORITY = "optional"
+DESCRIPTION = "Inputpipe is a network transparency layer for linux input devices"
+LICENSE = "GPL"
+#Remove the dash below when 0.5 changes in PV
+PV = "0.5+svn-${SRCDATE}"
+SRC_URI = "svn://svn.navi.cx/misc/trunk;module=inputpipe;proto=http"
+
+S = "${WORKDIR}/inputpipe"
+
+do_compile() {
+ oe_runmake CC="${CC}" CFLAGS="-I ${WORKDIR}/inputpipe/uinput ${CFLAGS}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install inputpipe-server ${D}${bindir}
+ install inputpipe-client ${D}${bindir}
+}
+
+PACKAGES = "${PN}-dbg inputpipe-server inputpipe-client ${PN}"
+
+FILES_inputpipe-client = "${bindir}/inputpipe-client"
+FILES_inputpipe-server = "${bindir}/inputpipe-server"