summaryrefslogtreecommitdiffstats
path: root/recipes/insttrain
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/insttrain
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/insttrain')
-rw-r--r--recipes/insttrain/files/gcc3.patch33
-rw-r--r--recipes/insttrain/insttrain_1.0.5.bb20
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes/insttrain/files/gcc3.patch b/recipes/insttrain/files/gcc3.patch
new file mode 100644
index 0000000000..c2e2af0c5e
--- /dev/null
+++ b/recipes/insttrain/files/gcc3.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- src/top.cpp~gcc3
++++ src/top.cpp
+@@ -18,6 +18,7 @@
+ //static char rcsid[] = "$Id: top.cpp,v 1.1 2002/10/06 04:17:00 bjj Rel $";
+
+ #include "top.h"
++#include <qapplication.h>
+ #include <qmenubar.h>
+ #include <qpopupmenu.h>
+ #include <qframe.h>
+@@ -90,7 +91,7 @@
+ }
+
+
+-Top::Top(QWidget *parent = 0, const char *name = 0, WFlags f = WType_TopLevel)
++Top::Top(QWidget *parent, const char *name, WFlags f)
+ : QMainWindow(parent, name, f)
+ {
+ setCaption("Instrument Trainer");
+@@ -172,7 +173,7 @@
+ void
+ Top::Exit()
+ {
+- exit(0);
++ qApp->quit();
+ }
+
+ void
diff --git a/recipes/insttrain/insttrain_1.0.5.bb b/recipes/insttrain/insttrain_1.0.5.bb
new file mode 100644
index 0000000000..7c163cbac3
--- /dev/null
+++ b/recipes/insttrain/insttrain_1.0.5.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Simulates any 2 of: DG, CDI for VOR1, CDI for VOR2, ADF, RMI \
+while you drag an NDB, 2 VORs and an airplane around in an overhead view."
+SECTION = "opie/applications"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPDESKTOP = "../Qtopia/opt/QtPalmtop/apps/Applications"
+
+inherit opie
+
+SRC_URI = "http://www.Vanille.de/mirror/insttrain-${PV}.tgz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/insttrain-${PV}/src"
+
+QMAKE_PROFILES = "rmi.pro"
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/
+ install -m 0644 ../Qtopia/opt/QtPalmtop/pics/*.png ${D}${palmtopdir}/pics/
+}
+