aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ipaq-boot-params
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ipaq-boot-params
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ipaq-boot-params')
-rw-r--r--recipes/ipaq-boot-params/files/h5000/params1
-rw-r--r--recipes/ipaq-boot-params/files/params1
-rw-r--r--recipes/ipaq-boot-params/ipaq-boot-params.bb16
3 files changed, 18 insertions, 0 deletions
diff --git a/recipes/ipaq-boot-params/files/h5000/params b/recipes/ipaq-boot-params/files/h5000/params
new file mode 100644
index 0000000000..fb42935fd5
--- /dev/null
+++ b/recipes/ipaq-boot-params/files/h5000/params
@@ -0,0 +1 @@
+set linuxargs "root=mtd1 noinitrd console=ttyS0,115200 console=tty0"
diff --git a/recipes/ipaq-boot-params/files/params b/recipes/ipaq-boot-params/files/params
new file mode 100644
index 0000000000..fb42935fd5
--- /dev/null
+++ b/recipes/ipaq-boot-params/files/params
@@ -0,0 +1 @@
+set linuxargs "root=mtd1 noinitrd console=ttyS0,115200 console=tty0"
diff --git a/recipes/ipaq-boot-params/ipaq-boot-params.bb b/recipes/ipaq-boot-params/ipaq-boot-params.bb
new file mode 100644
index 0000000000..216811ab56
--- /dev/null
+++ b/recipes/ipaq-boot-params/ipaq-boot-params.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Kernel boot parameters for HH.org bootldr"
+LICENSE = "MIT"
+PR = "r5"
+
+COMPATIBLE_MACHINE = "(h3600|h3800|h3900|h5000|simpad)"
+
+SRC_URI = "file://params"
+
+do_install() {
+ install -d ${D}/boot
+ install -m 0644 ${WORKDIR}/params ${D}/boot/
+}
+
+FILES_${PN} = "/boot/params"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+