aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iperf/iperf_1.7.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/iperf/iperf_1.7.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/iperf/iperf_1.7.0.bb')
-rw-r--r--recipes/iperf/iperf_1.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/iperf/iperf_1.7.0.bb b/recipes/iperf/iperf_1.7.0.bb
new file mode 100644
index 0000000000..1a5fec48d3
--- /dev/null
+++ b/recipes/iperf/iperf_1.7.0.bb
@@ -0,0 +1,26 @@
+SECTION = "console/network"
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+LICENSE = "BSD"
+PR = "r1"
+
+SRC_URI = "http://dast.nlanr.net/Projects/Iperf/iperf-${PV}-source.tar.gz \
+ file://socketaddr-h-errno.diff;patch=1"
+
+inherit autotools
+
+S="${WORKDIR}/iperf-${PV}/cfg"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
+}
+
+do_install() {
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake INSTALL_DIR=${D}${bindir} install
+}