aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iphone/iphone-rootfs_2.2.1.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-17 10:10:29 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-17 10:10:29 +0000
commit3e13bc01b22ef9b90e6fb2a268268d475d2625de (patch)
tree908b4aeaa036c0d096dc68d07f47be028942109a /recipes/iphone/iphone-rootfs_2.2.1.bb
parente0499fda0d4a459fc27dc1138f4943a0e1449db0 (diff)
downloadopenembedded-3e13bc01b22ef9b90e6fb2a268268d475d2625de.tar.gz
iphone: start adding toolchain elements for iphone
* iphone-sources: script to download and extract rootfs / SDKs * iphone-sources.manifest: config file describing a firmware version * iphone-rootfs.bb: stage libraries from firmware image * iphone-sdks.bb: stage headers from SDKS
Diffstat (limited to 'recipes/iphone/iphone-rootfs_2.2.1.bb')
-rw-r--r--recipes/iphone/iphone-rootfs_2.2.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/iphone/iphone-rootfs_2.2.1.bb b/recipes/iphone/iphone-rootfs_2.2.1.bb
new file mode 100644
index 0000000000..2978ab5329
--- /dev/null
+++ b/recipes/iphone/iphone-rootfs_2.2.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Staging iPhone root filesystem"
+DEPENDS = "apple-csu iphone-sdks"
+PROVIDES = "virtual/${TARGET_PREFIX}libc-for-gcc virtual/libc virtual/libiconv virtual/libintl libsegfault"
+
+INHIBIT_DEFAULT_DEPS = "1"
+EXCLUDE_FROM_SHLIBS = "1"
+
+# note: see iphone-sources script to get/generate the tarballs
+SRC_URI = "file://iphone-rootfs-${PV}.tar.bz2"
+
+FILES_${PN} += "/System ${layout_libdir}/*"
+
+do_compile () {
+ :
+}
+
+do_stage () {
+ cp -apR ${S}/usr/lib/* ${STAGING_LIBDIR}/
+ cp -apR ${S}/System ${STAGING_DIR_TARGET}/
+ rm -rf ${STAGING_DIR_TARGET}/System/Library/Fonts
+ rm -rf ${STAGING_DIR_TARGET}/System/Library/Audio
+ rm -rf ${STAGING_DIR_TARGET}/System/Library/Caches
+}