aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iphone
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-17 10:23:59 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-17 10:23:59 +0000
commit5d90e1e748839b19a260ca65c0f90183091a8b95 (patch)
tree69c72203e91c9a99325851fc3b7e756bd2583c44 /recipes/iphone
parente7f0c7a787ed434261998cdf31034b658625d051 (diff)
downloadopenembedded-5d90e1e748839b19a260ca65c0f90183091a8b95.tar.gz
gcc-iphone-cross: add rough cross-compiler for iPhone
Diffstat (limited to 'recipes/iphone')
-rw-r--r--recipes/iphone/gcc-iphone-cross_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/iphone/gcc-iphone-cross_git.bb b/recipes/iphone/gcc-iphone-cross_git.bb
new file mode 100644
index 0000000000..ea351cf0bf
--- /dev/null
+++ b/recipes/iphone/gcc-iphone-cross_git.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "GCC for iPhone"
+DEPENDS = "iphone-sdks"
+PV = "4.2.1+git${SRCREV}"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+PROVIDES += "virtual/${TARGET_PREFIX}gcc-initial virtual/${TARGET_PREFIX}gcc-intermediate"
+DEPENDS = "virtual/${TARGET_PREFIX}binutils bison-native flex-native iphone-rootfs"
+
+SRCREV = "b3dd8400196ccb63fbf10fe036f9f8725b2f0a39"
+SRC_URI = "git://git.saurik.com/llvm-gcc-4.2.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools cross
+
+EXTRA_OECONF = "\
+ --enable-languages=c,c++,objc,obj-c++ \
+ --enable-sjlj-exceptions \
+ --enable-wchar_t=no \
+ --with-gxx-include-dir=${STAGING_DIR_TARGET}/${layout_includedir}/c++ \
+ --with-as=${CROSS_DIR}/bin/${TARGET_PREFIX}as \
+ --with-ld=${CROSS_DIR}/bin/${TARGET_PREFIX}ld \
+ --with-sysroot=${STAGING_DIR_TARGET} \
+ --with-build-sysroot=${STAGING_DIR_TARGET} \
+ --with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
+ "
+
+do_configure() {
+ oe_runconf
+ rm -f GNUmakefile
+}
+