summaryrefslogtreecommitdiffstats
path: root/recipes/iproute2
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-08-20 12:58:19 +0400
committerRoman I Khimov <khimov@altell.ru>2010-08-22 20:07:33 +0400
commit003f28c9cab4966f3f30f132ac6b89d4f1c74d8a (patch)
tree245abefddc3fe955c7ab891c208cab8ce3eed79b /recipes/iproute2
parent82327c5e204720137d2b4039563f980b457bdad3 (diff)
downloadopenembedded-003f28c9cab4966f3f30f132ac6b89d4f1c74d8a.tar.gz
iproute2: add version 2.6.35
Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/iproute2')
-rw-r--r--recipes/iproute2/iproute2-2.6.35/configure-cross.patch58
-rw-r--r--recipes/iproute2/iproute2_2.6.35.bb19
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes/iproute2/iproute2-2.6.35/configure-cross.patch b/recipes/iproute2/iproute2-2.6.35/configure-cross.patch
new file mode 100644
index 0000000000..631d6bf958
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.35/configure-cross.patch
@@ -0,0 +1,58 @@
+Index: iproute2-2.6.34/configure
+===================================================================
+--- iproute2-2.6.34.orig/configure
++++ iproute2-2.6.34/configure
+@@ -4,7 +4,7 @@
+ INCLUDE=${1:-"$PWD/include"}
+
+ TABLES=
+-
++SYSROOT=$1
+ check_atm()
+ {
+ cat >/tmp/atmtest.c <<EOF
+@@ -15,7 +15,7 @@ int main(int argc, char **argv) {
+ return 0;
+ }
+ EOF
+-gcc -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
++$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+ echo "TC_CONFIG_ATM:=y" >>Config
+@@ -49,7 +49,7 @@ int main(int argc, char **argv)
+
+ EOF
+
+-if gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
++if $CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
+ then
+ echo "TC_CONFIG_XT:=y" >>Config
+ echo "using xtables"
+@@ -86,7 +86,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -126,7 +126,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -150,7 +150,7 @@ check_ipt()
+ check_ipt_lib_dir()
+ {
+ IPT_LIB_DIR=""
+- for dir in /lib /usr/lib /usr/local/lib
++ for dir in $SYSROOT/lib $SYSROOT/usr/lib $SYSROOT/usr/local/lib
+ do
+ for file in $dir/$TABLES/lib*t_*so ; do
+ if [ -f $file ]; then
diff --git a/recipes/iproute2/iproute2_2.6.35.bb b/recipes/iproute2/iproute2_2.6.35.bb
new file mode 100644
index 0000000000..eaa511f021
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.35.bb
@@ -0,0 +1,19 @@
+require iproute2.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://devresources.linuxfoundation.org/dev/iproute2/download/${P}.tar.bz2 \
+ file://configure-cross.patch \
+ "
+
+SRC_URI[md5sum] = "b0f281b3124bf04669e18f5fe16d4934"
+SRC_URI[sha256sum] = "8ab2f47e129925fb8acb09421008d07aeafa01b2ddd1fcba4a056de079f090a3"
+
+S = "${WORKDIR}/iproute2-${PV}"
+
+do_configure () {
+ ./configure ${STAGING_DIR_TARGET}
+}
+
+FILES_${PN} += "${base_libdir}/tc/*.so"
+FILES_${PN}-dbg += "${base_libdir}/tc/.debug" \ No newline at end of file