aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-12-16 17:37:55 -0800
committerKhem Raj <raj.khem@gmail.com>2009-12-16 17:37:55 -0800
commitda29e9aaa051f40665f818fe5884725047288a2f (patch)
tree33899d4a1f19eb2a61551f5432b26efd35767362 /recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
parent877f8c19536f671454e246f766bb7ac328fd4816 (diff)
downloadopenembedded-da29e9aaa051f40665f818fe5884725047288a2f.tar.gz
iptables_1.4.6.bb: Recipe for version 1.4.6.
* Switch to INC_PR. * inherit autotools Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch')
-rw-r--r--recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch b/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
new file mode 100644
index 0000000000..b833237c16
--- /dev/null
+++ b/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
@@ -0,0 +1,28 @@
+Index: iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ECN.h
+===================================================================
+--- iptables-1.4.6.orig/include/linux/netfilter_ipv4/ipt_ECN.h 2009-12-15 22:05:04.713075521 -0800
++++ iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ECN.h 2009-12-15 22:08:43.875470318 -0800
+@@ -8,9 +8,6 @@
+ */
+ #ifndef _IPT_ECN_TARGET_H
+ #define _IPT_ECN_TARGET_H
+-#include <linux/netfilter_ipv4/ipt_DSCP.h>
+-
+-#define IPT_ECN_IP_MASK (~IPT_DSCP_MASK)
+
+ #define IPT_ECN_OP_SET_IP 0x01 /* set ECN bits of IPv4 header */
+ #define IPT_ECN_OP_SET_ECE 0x10 /* set ECE bit of TCP header */
+Index: iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ecn.h
+===================================================================
+--- iptables-1.4.6.orig/include/linux/netfilter_ipv4/ipt_ecn.h 2009-12-15 22:09:44.415445160 -0800
++++ iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ecn.h 2009-12-15 22:09:58.523715835 -0800
+@@ -8,9 +8,6 @@
+ */
+ #ifndef _IPT_ECN_H
+ #define _IPT_ECN_H
+-#include <linux/netfilter_ipv4/ipt_dscp.h>
+-
+-#define IPT_ECN_IP_MASK (~IPT_DSCP_MASK)
+
+ #define IPT_ECN_OP_MATCH_IP 0x01
+ #define IPT_ECN_OP_MATCH_ECE 0x10