aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iptables/iptables_1.3.8.bb
diff options
context:
space:
mode:
authorChris Larson <clarson@mvista.com>2010-01-06 16:32:40 -0700
committerChris Larson <clarson@mvista.com>2010-01-22 09:39:10 -0700
commitc6088e990601e67708bba32a45a92aecb7e43d5c (patch)
tree057bf665963064573785940fd9a90bad5ca81b22 /recipes/iptables/iptables_1.3.8.bb
parent0174458a6214e8111f527c0030a868aecf876e05 (diff)
downloadopenembedded-c6088e990601e67708bba32a45a92aecb7e43d5c.tar.gz
iptables: unbork the 1.3.8 build, merge iptables-utils into iptables.
In recent iptables versions, the -save and -restore files are just symlinks pointing to the main, merged binary, so the separate package is a bit unnecessary. Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/iptables/iptables_1.3.8.bb')
-rw-r--r--recipes/iptables/iptables_1.3.8.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/iptables/iptables_1.3.8.bb b/recipes/iptables/iptables_1.3.8.bb
index 47c5564997..968f7d99af 100644
--- a/recipes/iptables/iptables_1.3.8.bb
+++ b/recipes/iptables/iptables_1.3.8.bb
@@ -1,5 +1,16 @@
require iptables.inc
PR = "${INC_PR}.0"
+EXTRA_OEMAKE = "'COPT_FLAGS=${CFLAGS}' \
+ 'KERNEL_DIR=${STAGING_INCDIR}' \
+ 'LDFLAGS=${LDFLAGS}' \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', 'DO_IPV6=1', 'DO_IPV6=0', d)} \
+ \
+ 'PREFIX=${prefix}' \
+ 'LIBDIR=${libdir}' \
+ 'BINDIR=${sbindir}' \
+ 'MANDIR=${mandir}' \
+ 'INCDIR=${includedir}'"
+CFLAGS[unexport] = "1"
SRC_URI += "\
file://getsockopt-failed.patch;patch=1 \
@@ -7,3 +18,6 @@ SRC_URI += "\
file://cross-iptables.diff;patch=1 \
"
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}