summaryrefslogtreecommitdiffstats
path: root/recipes/iptables
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2009-07-14 19:10:03 -0700
committerChris Larson <clarson@mvista.com>2009-08-27 13:21:16 -0700
commitf0b67d21ab82330aceee1f32d46add93b87875e4 (patch)
treec20be7dde62161f398fd44d4b550452ba47e8c3a /recipes/iptables
parent87b8c170f803d601fff8d2b876ce14518d59f70e (diff)
downloadopenembedded-f0b67d21ab82330aceee1f32d46add93b87875e4.tar.gz
iptables: Add patch to use cross ar and ranlib.
Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/iptables')
-rw-r--r--recipes/iptables/files/cross-iptables.diff15
-rw-r--r--recipes/iptables/iptables_1.3.8.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/iptables/files/cross-iptables.diff b/recipes/iptables/files/cross-iptables.diff
new file mode 100644
index 0000000000..8027b07bca
--- /dev/null
+++ b/recipes/iptables/files/cross-iptables.diff
@@ -0,0 +1,15 @@
+--- a/extensions/Makefile~ 2007-03-21 17:04:36.000000000 -0700
++++ b/extensions/Makefile 2009-07-14 19:01:56.000000000 -0700
+@@ -80,10 +80,10 @@
+
+ ifdef NO_SHARED_LIBS
+ extensions/libext.a: $(EXT_OBJS)
+- rm -f $@; ar crv $@ $(EXT_OBJS)
++ rm -f $@; $(AR) crv $@ $(EXT_OBJS); $(RANLIB) $@
+
+ extensions/libext6.a: $(EXT6_OBJS)
+- rm -f $@; ar crv $@ $(EXT6_OBJS)
++ rm -f $@; $(AR) crv $@ $(EXT6_OBJS); $(RANLIB) $@
+
+ extensions/initext.o: extensions/initext.c
+ extensions/initext6.o: extensions/initext6.c
diff --git a/recipes/iptables/iptables_1.3.8.bb b/recipes/iptables/iptables_1.3.8.bb
index 040be0643f..520e33624d 100644
--- a/recipes/iptables/iptables_1.3.8.bb
+++ b/recipes/iptables/iptables_1.3.8.bb
@@ -1,8 +1,9 @@
require iptables.inc
-PR = "r4"
+PR = "r5"
SRC_URI += "\
file://getsockopt-failed.patch;patch=1 \
file://iptables-use-s6_addr32.patch;patch=1 \
+ file://cross-iptables.diff;patch=1 \
"