aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iputils
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-16 16:08:55 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-16 16:08:55 +0200
commite33293bf4db621de992d73406d24b9c86b542b1b (patch)
tree4e278b033c36ce82bbf56e9008009f73c2aa7b54 /recipes/iputils
parent8687813463bc7c9f37349000f75cfc0967da8458 (diff)
downloadopenembedded-e33293bf4db621de992d73406d24b9c86b542b1b.tar.gz
iputils 20071127: touch up debian patches
Diffstat (limited to 'recipes/iputils')
-rw-r--r--recipes/iputils/files/debian/fix-cmsghdr-offset-bug.diff18
-rw-r--r--recipes/iputils/iputils_20071127.bb5
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/iputils/files/debian/fix-cmsghdr-offset-bug.diff b/recipes/iputils/files/debian/fix-cmsghdr-offset-bug.diff
index 7ae92df468..0c9bbd8ea0 100644
--- a/recipes/iputils/files/debian/fix-cmsghdr-offset-bug.diff
+++ b/recipes/iputils/files/debian/fix-cmsghdr-offset-bug.diff
@@ -17,3 +17,21 @@
ICMP6_FILTER_SETBLOCKALL(&filter);
if (!working_recverr) {
+--- /tmp/ping6.c 2009-06-15 19:13:57.000000000 +0200
++++ iputils_20071127.orig/ping6.c 2009-06-15 19:14:40.000000000 +0200
+@@ -415,14 +415,9 @@
+ exit(2);
+ }
+ cmsg = (struct cmsghdr*)(cmsgbuf+cmsglen);
+- cmsglen += CMSG_SPACE(sizeof(*ipi));
+- cmsg->cmsg_len = CMSG_LEN(sizeof(*ipi));
++ cmsglen += CMSG_SPACE(sizeof(ipi));
+ cmsg->cmsg_level = SOL_IPV6;
+ cmsg->cmsg_type = IPV6_PKTINFO;
+-
+- ipi = (struct in6_pktinfo*)CMSG_DATA(cmsg);
+- memset(ipi, 0, sizeof(*ipi));
+- ipi->ipi6_ifindex = ifr.ifr_ifindex;
+ }
+
+ if ((whereto.sin6_addr.s6_addr16[0]&htons(0xff00)) == htons (0xff00)) {
diff --git a/recipes/iputils/iputils_20071127.bb b/recipes/iputils/iputils_20071127.bb
index 9235a65c52..821d6c9c2f 100644
--- a/recipes/iputils/iputils_20071127.bb
+++ b/recipes/iputils/iputils_20071127.bb
@@ -4,8 +4,11 @@ tracepath, tracepath6, ping, ping6 and arping."
SECTION = "console/network"
LICENSE ="BSD"
+PR = "r1"
+
#Need more testing
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "2"
SRC_URI = "http://ftp.de.debian.org/debian/pool/main/i/iputils/iputils_${PV}.orig.tar.gz \
file://debian/fix-dead-host-ping-stats.diff;patch=1 \
@@ -52,7 +55,7 @@ do_install () {
done
# Manual pages for things we build packages for
for i in tracepath.8 traceroute6.8 ping.8 arping.8; do
- install -m 0644 doc/$i ${D}${mandir}/man8/
+ install -m 0644 doc/$i ${D}${mandir}/man8/ || true
done
}