aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/irda-utils/irda-utils_0.9.16.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/irda-utils/irda-utils_0.9.16.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/irda-utils/irda-utils_0.9.16.bb')
-rw-r--r--recipes/irda-utils/irda-utils_0.9.16.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/irda-utils/irda-utils_0.9.16.bb b/recipes/irda-utils/irda-utils_0.9.16.bb
new file mode 100644
index 0000000000..19bcdf397c
--- /dev/null
+++ b/recipes/irda-utils/irda-utils_0.9.16.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Provides common files needed to use IrDA. \
+IrDA allows communication over Infrared with other devices \
+such as phones and laptops."
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r8"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://m4.patch;patch=1 \
+ file://init"
+
+export SYS_INCLUDES="-I${STAGING_INCDIR}"
+
+inherit autotools
+
+INITSCRIPT_NAME = "irattach"
+INITSCRIPT_PARAMS = "defaults 20"
+
+do_compile () {
+ oe_runmake -e -C irattach
+ oe_runmake -e -C irdaping
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ oe_runmake -C irattach ROOT="${D}" install
+ oe_runmake -C irdaping ROOT="${D}" install
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
+}