aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/irk
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/irk
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/irk')
-rw-r--r--recipes/irk/files/install-default-conf.patch18
-rw-r--r--recipes/irk/irk-belkin_0.11.bb9
-rw-r--r--recipes/irk/irk-targus_0.11.0.bb11
-rw-r--r--recipes/irk/irk.inc24
4 files changed, 62 insertions, 0 deletions
diff --git a/recipes/irk/files/install-default-conf.patch b/recipes/irk/files/install-default-conf.patch
new file mode 100644
index 0000000000..a55992a737
--- /dev/null
+++ b/recipes/irk/files/install-default-conf.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- irk/irk.cpp~install-default-config
++++ irk/irk.cpp
+@@ -470,6 +470,10 @@
+
+ void CGIRK::readConfig()
+ {
++ // check if the config is there, if not copy it from default location
++ // FIXME: Do it properly once confirmed that it works :D
++ ::system( "if [ ! -e \"$HOME/Settings/IRK.conf\" ]; then cat $OPIEDIR/etc/skel/IRK.conf >$HOME/Settings/IRK.conf; fi" );
++
+ // clear the keyboard list ready for the new one to be loaded in
+ m_keyboardList.clear();
+ #if !POCKETOP_BUILD
diff --git a/recipes/irk/irk-belkin_0.11.bb b/recipes/irk/irk-belkin_0.11.bb
new file mode 100644
index 0000000000..e543ebdcc5
--- /dev/null
+++ b/recipes/irk/irk-belkin_0.11.bb
@@ -0,0 +1,9 @@
+require irk.inc
+
+DESCRIPTION += "(version with Belkin support)"
+RCONFLICTS = "irk-targus"
+RREPLACES = "irk-targus"
+PR = "r3"
+
+SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/sources/irk-current.tgz \
+ file://install-default-conf.patch;patch=1"
diff --git a/recipes/irk/irk-targus_0.11.0.bb b/recipes/irk/irk-targus_0.11.0.bb
new file mode 100644
index 0000000000..87b74cb5eb
--- /dev/null
+++ b/recipes/irk/irk-targus_0.11.0.bb
@@ -0,0 +1,11 @@
+require irk.inc
+PR = "r2"
+
+DESCRIPTION += "(version with Targus support)"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+
+RCONFLICTS = "irk-belkin"
+RREPLACES = "irk-belkin"
+
+SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/www.openzaurus.org/official/unstable/3.5.4/sources/irk-${PV}.tgz \
+ file://install-default-conf.patch;patch=1"
diff --git a/recipes/irk/irk.inc b/recipes/irk/irk.inc
new file mode 100644
index 0000000000..b00583c22b
--- /dev/null
+++ b/recipes/irk/irk.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus."
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+DEPENDS = "lirc"
+
+S = "${WORKDIR}/irk"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
+
+do_install() {
+ install -d ${D}${sysconfdir}/
+ install -d ${D}${palmtopdir}/etc/skel/
+ install -d ${D}${palmtopdir}/plugins/inputmethods/
+
+ install -m 0644 chicony.conf ${D}${sysconfdir}/lircd.conf
+ install -m 0644 IRK.conf ${D}${palmtopdir}/etc/skel/
+ oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
+}
+
+FILES_${PN} += "${sysconfdir}"