aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb')
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
new file mode 100644
index 0000000000..9db83352c4
--- /dev/null
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Firmware converter for the IXP4xx line of devices"
+LICENSE = "Intel Public Licence"
+PR = "r1"
+
+SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
+SRC_URI += "file://IxNpeMicrocode.h"
+inherit native
+S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
+
+do_compile() {
+ mv ${WORKDIR}/IxNpeMicrocode.h ${S}/
+ gcc -Wall IxNpeMicrocode.c -o IxNpeMicrocode
+}
+
+do_stage() {
+ mv ${S}/IxNpeMicrocode ${S}/IxNpeMicrocode-${PV}
+ install -d ${STAGING_BINDIR}/
+ install -m 0755 ${S}/IxNpeMicrocode-${PV} ${STAGING_BINDIR}/
+}