aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jaaa/clthreads_2.4.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jaaa/clthreads_2.4.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jaaa/clthreads_2.4.0.bb')
-rw-r--r--recipes/jaaa/clthreads_2.4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/jaaa/clthreads_2.4.0.bb b/recipes/jaaa/clthreads_2.4.0.bb
new file mode 100644
index 0000000000..ac67c5028d
--- /dev/null
+++ b/recipes/jaaa/clthreads_2.4.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "clthreads library from http://www.kokkinizita.net/linuxaudio/"
+SECTION = "libs/multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+PR = "r0"
+
+DEPENDS = ""
+
+SRC_URI = "http://www.kokkinizita.net/linuxaudio/downloads/clthreads-${PV}.tar.bz2 \
+ file://clthreads-Makefile.patch;patch=1 \
+"
+
+S = "${WORKDIR}/clthreads-${PV}"
+
+inherit autotools pkgconfig lib_package
+
+do_stage() {
+ autotools_stage_all
+ oe_libinstall -so libclthreads ${STAGING_LIBDIR}
+ install -m 0644 clthreads.h ${STAGING_INCDIR}
+}