aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jaaa
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-27 00:03:17 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-27 00:03:17 -0700
commit0c958cb549e0ec0ca49378d0decd10ba1fc0094d (patch)
tree3700dbf19fe791981e84a85c733b77f1511965fb /recipes/jaaa
parent0058d3f85fa04555f024b4eccd5df30d94c091fc (diff)
downloadopenembedded-0c958cb549e0ec0ca49378d0decd10ba1fc0094d.tar.gz
clxclient_3.6.1.bb: Fix compilation, do not inherit autotools
* This does not use autoconf or automake so no need to inherit it * Do not override CFLAGS and add freetype include path to compiler include search paths Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/jaaa')
-rw-r--r--recipes/jaaa/clxclient_3.6.1.bb15
1 files changed, 7 insertions, 8 deletions
diff --git a/recipes/jaaa/clxclient_3.6.1.bb b/recipes/jaaa/clxclient_3.6.1.bb
index 678ea4549e..9aa2135174 100644
--- a/recipes/jaaa/clxclient_3.6.1.bb
+++ b/recipes/jaaa/clxclient_3.6.1.bb
@@ -1,24 +1,23 @@
DESCRIPTION = "clxclient library from http://www.kokkinizita.net/linuxaudio/"
SECTION = "libs/multimedia"
PRIORITY = "optional"
-LICENSE = "LGPL"
-PR = "r1"
+LICENSE = "LGPLv2.1+"
+PR = "r2"
DEPENDS = "libx11 clthreads freetype libxft"
RDEPENDS_${PN} = "libx11-locale"
-
+TARGET_CC_ARCH += "-I ${STAGING_DIR_HOST}/usr/include/freetype2"
SRC_URI = "http://www.kokkinizita.net/linuxaudio/downloads/clxclient-${PV}.tar.bz2 \
file://clxclient-Makefile.patch \
"
S = "${WORKDIR}/clxclient-${PV}"
-inherit autotools pkgconfig lib_package
+inherit pkgconfig lib_package
-do_stage() {
- autotools_stage_all
- oe_libinstall -so libclxclient ${STAGING_LIBDIR}
- install -m 0644 clxclient.h ${STAGING_INCDIR}
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS
+ oe_runmake
}
SRC_URI[md5sum] = "bd47f80a855d3203fcf10365e79d85e4"