aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jack/jack_0.116.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jack/jack_0.116.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jack/jack_0.116.2.bb')
-rw-r--r--recipes/jack/jack_0.116.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/jack/jack_0.116.2.bb b/recipes/jack/jack_0.116.2.bb
new file mode 100644
index 0000000000..f0a2e7525e
--- /dev/null
+++ b/recipes/jack/jack_0.116.2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "JACK is a low-latency audio server. It can \
+connect a number of different applications to an audio \
+device, as well as allowing them to share audio between \
+themselves."
+SECTION = "libs/multimedia"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+PR = "r0"
+
+DEPENDS = "alsa-lib"
+
+SRC_URI = "http://jackaudio.org/downloads/jack-audio-connection-kit-${PV}.tar.gz"
+S = "${WORKDIR}/jack-audio-connection-kit-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-timestamps --disable-capabilities --disable-oldtrans \
+ --disable-portaudio --disable-coreaudio --enable-oss --enable-alsa"
+
+EXTRA_OEMAKE = 'transform="s,^,,"'
+LDFLAGS_append = " -ldl -L${STAGING_LIBDIR}"
+
+PACKAGES =+ "libjack jack-server jack-examples"
+
+FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
+FILES_jack-server = "${bindir}/jackd"
+FILES_jack-examples = "${bindir}/*"
+
+do_stage() {
+ autotools_stage_all
+}
+