aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jack
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2011-02-26 11:49:06 +0100
committerTom Rini <tom_rini@mentor.com>2011-02-26 10:37:14 -0700
commit884e3ae5d876163c83ef70c4af2c12f6d27599c7 (patch)
treea097f8c4029c96f1d47238f19f5a9285b87dafd5 /recipes/jack
parentb93d21c42d28adb2562ccd1ec97338a125fefc47 (diff)
downloadopenembedded-884e3ae5d876163c83ef70c4af2c12f6d27599c7.tar.gz
jack: fix wrong configure check on the build host
| checking existing, conflicting JACK installs... | You appear to have at least one existing installation of JACK. | Complete or partial JACK installs exist in: /usr/lib [...] NOTE: package jack-0.118.0-r2: task do_configure: Failed Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/jack')
-rw-r--r--recipes/jack/files/remove-wrong-host-test.patch66
-rw-r--r--recipes/jack/jack_0.118.0.bb6
2 files changed, 70 insertions, 2 deletions
diff --git a/recipes/jack/files/remove-wrong-host-test.patch b/recipes/jack/files/remove-wrong-host-test.patch
new file mode 100644
index 0000000000..54c4a833f7
--- /dev/null
+++ b/recipes/jack/files/remove-wrong-host-test.patch
@@ -0,0 +1,66 @@
+| checking existing, conflicting JACK installs...
+|
+| !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+| You appear to have at least one existing installation of JACK.
+| Complete or partial JACK installs exist in: /usr/lib
+
+[...]
+
+NOTE: package jack-0.118.0-r2: task do_configure: Failed
+
+Index: RELEASE_0_118_0/configure.ac
+===================================================================
+--- RELEASE_0_118_0.orig/configure.ac 2011-02-26 06:54:25.711716288 +0100
++++ RELEASE_0_118_0/configure.ac 2011-02-26 06:54:47.061718126 +0100
+@@ -3,51 +3,6 @@
+
+ AC_INIT(jackd/jackd.c)
+
+-
+-dnl
+-dnl Check for existing JACK installs
+-dnl
+-
+-AC_MSG_CHECKING([existing, conflicting JACK installs])
+-not_overwriting=0
+-installs=
+-for dir in /usr/lib /usr/local/lib /opt/lib ; do
+- if test -d $dir ; then
+- if test $(find $dir/ -name 'libjack.*' 2>/dev/null | wc -l) -gt 0 ; then
+- if echo $prefix/lib | grep -vs $dir >/dev/null 2>&1 ; then
+- not_overwriting=$(expr $not_overwriting + 1)
+- fi
+- installs="$installs $dir"
+- fi
+- fi
+-done
+-
+-if test $not_overwriting -gt 0 ; then
+- echo
+- echo
+- echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+- echo "You appear to have at least one existing installation of JACK."
+- echo
+- echo "Complete or partial JACK installs exist in:$installs"
+- echo
+- echo "Installing this version will leave at least one of these"
+- echo "existing installations installed and this will probably break"
+- echo "JACK on your machine. "
+- echo
+- echo "Before building, you should first remove the existing JACK"
+- echo "installation(s). "
+- echo
+- echo "Alternatively use ./configure --prefix=... to force overwriting"
+- echo "the existing install."
+- echo
+- echo "WARNING: ON ANY DEBIAN-DERIVED DISTRIBUTION (Debian, Ubuntu etc)"
+- echo "CHANGING THE INSTALLATION PREFIX WILL NOT PRODUCE A WORKING JACK"
+- echo "INSTALL. Please contact the distribution packager for JACK and"
+- echo "ask them to fix their packaging."
+- echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+- exit 1
+-fi
+-
+ AC_CONFIG_AUX_DIR(config)
+ AC_CANONICAL_TARGET
+
diff --git a/recipes/jack/jack_0.118.0.bb b/recipes/jack/jack_0.118.0.bb
index 5ca9d658c3..e979c7a57c 100644
--- a/recipes/jack/jack_0.118.0.bb
+++ b/recipes/jack/jack_0.118.0.bb
@@ -8,11 +8,13 @@ LICENSE = "GPLv2 LGPLv2.1"
DEPENDS = "alsa-lib"
-PR = "r2"
+PR = "r3"
SVNPV = "${@'${PV}'.replace('.', '_')}"
SRCREV = "4084"
-SRC_URI = "svn://subversion.jackaudio.org/jack/tags;module=RELEASE_${SVNPV};proto=http"
+SRC_URI = "svn://subversion.jackaudio.org/jack/tags;module=RELEASE_${SVNPV};proto=http \
+ file://remove-wrong-host-test.patch \
+ "
# This is not omap3 specific, but there is a strong correlation between using twl4030 and using omap3
SRC_URI_append_omap3 = " file://jack_fix_TWL4030_alsa_capture.patch"