aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jakarta-libs
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:54:58 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 13:54:58 +0200
commitf4a8de9123820855fcb4efd1a1755ead587a7fa7 (patch)
tree16556780f40ede73e2f762d0e380613f9dcfe50c /recipes/jakarta-libs
parente48d77d6dca005d16345c004caf1be716db12e3b (diff)
downloadopenembedded-f4a8de9123820855fcb4efd1a1755ead587a7fa7.tar.gz
regexp 1.5: New recipe (from Jalimo SVN).
regexp-native 1.5: Dito.
Diffstat (limited to 'recipes/jakarta-libs')
-rw-r--r--recipes/jakarta-libs/regexp-native_1.5.bb4
-rw-r--r--recipes/jakarta-libs/regexp_1.5.bb19
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/regexp-native_1.5.bb b/recipes/jakarta-libs/regexp-native_1.5.bb
new file mode 100644
index 0000000000..679da37783
--- /dev/null
+++ b/recipes/jakarta-libs/regexp-native_1.5.bb
@@ -0,0 +1,4 @@
+require regexp_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/jakarta-libs/regexp_1.5.bb b/recipes/jakarta-libs/regexp_1.5.bb
new file mode 100644
index 0000000000..9ae6c35d42
--- /dev/null
+++ b/recipes/jakarta-libs/regexp_1.5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Java Regular Expression package"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/jakarta-${BP}"
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath src/java -d build `find src/java -name \*.java`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}