aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jamvm
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-29 11:07:11 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-29 11:08:04 +0200
commitd295fc9fefc34f03e3b8d1b87f8658119cae1437 (patch)
tree8f047eab23ded9ad63fc1df9fef005c7821551fe /recipes/jamvm
parent2676a3c9193804ad9047bed88314718efcb3d057 (diff)
downloadopenembedded-d295fc9fefc34f03e3b8d1b87f8658119cae1437.tar.gz
jamvm-initial 1.x.y: Use 512MB for Xmx by default, install libjvm in private directory.
Diffstat (limited to 'recipes/jamvm')
-rw-r--r--recipes/jamvm/jamvm-initial_1.4.5.bb8
-rw-r--r--recipes/jamvm/jamvm-initial_1.5.0.bb6
2 files changed, 11 insertions, 3 deletions
diff --git a/recipes/jamvm/jamvm-initial_1.4.5.bb b/recipes/jamvm/jamvm-initial_1.4.5.bb
index c71811dd4e..1566deba61 100644
--- a/recipes/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes/jamvm/jamvm-initial_1.4.5.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "zlib-native classpath-initial jikes-initial"
-PR = "r0"
+PR = "r1"
PROVIDES = "virtual/java-initial"
@@ -19,12 +19,16 @@ ARM_INSTRUCTION_SET = "arm"
inherit native autotools
+# libdir must be modified so that jamvm-initial and -native
+# do not interfere
EXTRA_OECONF = "\
--with-classpath-install-dir=${prefix} \
--program-suffix=-initial \
+ --libdir=${STAGING_LIBDIR}/jamvm-initial \
"
-CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
+# jamvm-initial has to run some binaries which need lots of memory.
+CFLAGS += "-DDEFAULT_MAX_HEAP=512*MB"
do_compile() {
oe_runmake \
diff --git a/recipes/jamvm/jamvm-initial_1.5.0.bb b/recipes/jamvm/jamvm-initial_1.5.0.bb
index a1c415dd62..1566deba61 100644
--- a/recipes/jamvm/jamvm-initial_1.5.0.bb
+++ b/recipes/jamvm/jamvm-initial_1.5.0.bb
@@ -19,12 +19,16 @@ ARM_INSTRUCTION_SET = "arm"
inherit native autotools
+# libdir must be modified so that jamvm-initial and -native
+# do not interfere
EXTRA_OECONF = "\
--with-classpath-install-dir=${prefix} \
--program-suffix=-initial \
+ --libdir=${STAGING_LIBDIR}/jamvm-initial \
"
-CFLAGS += "-DDEFAULT_MAX_HEAP=16*MB"
+# jamvm-initial has to run some binaries which need lots of memory.
+CFLAGS += "-DDEFAULT_MAX_HEAP=512*MB"
do_compile() {
oe_runmake \