aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jards
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jards
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jards')
-rw-r--r--recipes/jards/jards_1.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes/jards/jards_1.0.bb b/recipes/jards/jards_1.0.bb
new file mode 100644
index 0000000000..c0504ae88c
--- /dev/null
+++ b/recipes/jards/jards_1.0.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "Reference and training tool for students of Japanese"
+AUTHOR = "Johnny Andersson"
+HOMEPAGE = "http://gakusei.sf.net"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "virtual/japanese-font qte-mt libpng (>= 1) kpengine"
+PR = "r7"
+
+# stuff that still needs fixing
+#) is the RDEPENDS line correct and sufficient?
+#) upon execution there is a message that /usr/lib/libpng12.so.0 does not have version information
+#) desktop icon missing
+#) Desktop png file an falscher Stelle, daher kein Icon
+#) remove .debug dir
+#) es fehlen: ./opt/QtPalmtop/bin/kpengine, ./opt/QtPalmtop/jardsmob/edict.jardsdic, ./opt/QtPalmtop/jardsmob/kanjidic.jardskdic
+#) exec muß jardsmob_bin heißen
+#) Programm geht oft in 100% CPU schleife -> unbenutzbar
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/jards_gakusei.cvs.sourceforge.net__20070212.tar.gz"
+#SRC_URI = "cvs://anonymous@gakusei.cvs.sourceforge.net/cvsroot/gakusei;method=pserver;module=jards"
+
+inherit opie
+
+OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
+
+S = "${WORKDIR}/${PN}/"
+export OE_QMAKE_LINK="${CXX}"
+
+# read opie.bbclass
+#APPDESKTOP = "${S}"
+APPTYPE = "binary"
+APPNAME = "jardsmob"
+
+FILES_${PN}-dbg += "${D}${palmtopdir}/bin/.debug/"
+
+PARALLEL_MAKE = ""
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+ install -d ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/${APPNAME}/images
+ install -d ${D}${palmtopdir}/apps/Applications
+ install -m 0644 ${S}dat/images/jardsmob.png ${D}${palmtopdir}/pics/
+ install -m 0644 ${S}dat/images/*.png ${D}${palmtopdir}/${APPNAME}/images/
+ install -m 0755 ${S}jardsmob_bin ${D}${palmtopdir}/bin/
+ install -m 0644 ${WORKDIR}/jards/jards.desktop ${D}${palmtopdir}/apps/Applications/
+
+ # what about the following files: edict.jardsdic kanjidic.jardskdic?
+ for f in markers romkana.utf8 strokedata wordfreq_ck raddat.utf8
+ do
+ install -m 0644 ${S}dat/$f ${D}${palmtopdir}/${APPNAME}/
+ done
+}
+