aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jdepend
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:18:50 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:18:50 +0200
commit7b686c7c52bd214593ed21f3715cb5656c74916b (patch)
tree4491c9f3cc234c1c57e028defd5a18a2986ba9bc /recipes/jdepend
parent02d7af7ebb75a90929200905cfb6d3f8b07dbd11 (diff)
downloadopenembedded-7b686c7c52bd214593ed21f3715cb5656c74916b.tar.gz
jdepend 2.9: New recipe (from Jalimo SVN).
jdepend-native 2.9: Dito.
Diffstat (limited to 'recipes/jdepend')
-rw-r--r--recipes/jdepend/jdepend-native_2.9.bb4
-rw-r--r--recipes/jdepend/jdepend_2.9.bb20
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/jdepend/jdepend-native_2.9.bb b/recipes/jdepend/jdepend-native_2.9.bb
new file mode 100644
index 0000000000..dc6251746e
--- /dev/null
+++ b/recipes/jdepend/jdepend-native_2.9.bb
@@ -0,0 +1,4 @@
+require jdepend_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/jdepend/jdepend_2.9.bb b/recipes/jdepend/jdepend_2.9.bb
new file mode 100644
index 0000000000..fc70eac442
--- /dev/null
+++ b/recipes/jdepend/jdepend_2.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Design quality metrics generator for each Java"
+
+# see http://www.clarkware.com/software/license.txt
+LICENSE = "BSD"
+
+HOMEPAGE = "http://clarkware.com/software/JDepend.html"
+
+SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath src -d build `find src -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}